summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-07-01 02:13:45 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-07-20 15:33:36 +0300
commit92417217106e67a42e2728006641f06b2e567040 (patch)
tree0c55498b2d67f21f031f34e3200460fc5d6bb504
parentapp-misc/gnutu: add myself as proxy maintainer (diff)
downloadgentoo-92417217106e67a42e2728006641f06b2e567040.tar.gz
gentoo-92417217106e67a42e2728006641f06b2e567040.tar.bz2
gentoo-92417217106e67a42e2728006641f06b2e567040.zip
dev-vcs/topgit: update version
Taking mantainership over package. Closes: https://bugs.gentoo.org/539288 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16517 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-vcs/topgit/Manifest1
-rw-r--r--dev-vcs/topgit/metadata.xml11
-rw-r--r--dev-vcs/topgit/topgit-0.19.12.ebuild32
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-vcs/topgit/Manifest b/dev-vcs/topgit/Manifest
index cd35df25b783..4f0d3325a71b 100644
--- a/dev-vcs/topgit/Manifest
+++ b/dev-vcs/topgit/Manifest
@@ -1 +1,2 @@
+DIST topgit-0.19.12.tar.gz 302492 BLAKE2B 5691823e58774883d33bc96e5d10b871a40224c97e3deb90f4fef051dbcecd6a7d3c979fe6b7e6c9aac64d485b9c4324b4d666a7ae64cb82cd325498d33e0cae SHA512 cb9245fbec7a4a15822a5b70d7052be200aa8b574b528dd929121597eb7dcec97532b0fd4d6a4d6bb63676194ed0ab2129e106fb88f63561187620ec431f9efb
DIST topgit-0.9.tar.gz 37025 BLAKE2B e28b0fd4cdf4cf063bad939c712fc9354ffc2d9c5e431f637e8306454d7a871268902253a1d2c59afa94406223b1fdc1627f3dda04586c88c0b609a72a1eaa87 SHA512 15b4ec44fb1711273155350924806f9ddce330251d3f300f5d2ecf445f4822c40b5c7309429876746ed8226c00f74292956f51f9126c8c359c3f4d589c73791c
diff --git a/dev-vcs/topgit/metadata.xml b/dev-vcs/topgit/metadata.xml
index a4bff25eb375..1c551510bec0 100644
--- a/dev-vcs/topgit/metadata.xml
+++ b/dev-vcs/topgit/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
- <remote-id type="github">greenrd/topgit</remote-id>
+ <remote-id type="github">mackyle/topgit</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-vcs/topgit/topgit-0.19.12.ebuild b/dev-vcs/topgit/topgit-0.19.12.ebuild
new file mode 100644
index 000000000000..eab7ae62e258
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.19.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://mackyle.github.io/topgit/topgit.html https://github.com/mackyle/topgit"
+SRC_URI="https://github.com/mackyle/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND=">=dev-vcs/git-2.10.0"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" sharedir="/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}