summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2024-10-24 11:11:00 -0400
committerZac Medico <zmedico@gentoo.org>2024-10-24 12:51:28 -0700
commit932b12cd4319a206933e1f548d0913ecbc1e8b91 (patch)
tree1cf272f987918881f94b3e08550158a0ae5035b4
parentdev-util/promu-0.15.0: disable pie on arm (diff)
downloadgentoo-932b12cd4319a206933e1f548d0913ecbc1e8b91.tar.gz
gentoo-932b12cd4319a206933e1f548d0913ecbc1e8b91.tar.bz2
gentoo-932b12cd4319a206933e1f548d0913ecbc1e8b91.zip
app-containers/podman: fix SELinux relabeling
The Makefile relabels the podman executable during installation and defaults to using container_runtime_exec_t which does not exist in Gentoo's SELinux policies. Disable the automatic relabeling during install and let portage take care of it to avoid this error. Closes: https://bugs.gentoo.org/927966 Signed-off-by: Kenton Groombridge <concord@gentoo.org> From: https://github.com/gentoo/gentoo/pull/39098 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-containers/podman/podman-4.9.4.ebuild2
-rw-r--r--app-containers/podman/podman-5.0.2.ebuild4
-rw-r--r--app-containers/podman/podman-5.0.3.ebuild4
-rw-r--r--app-containers/podman/podman-5.1.1.ebuild4
-rw-r--r--app-containers/podman/podman-5.2.4.ebuild4
-rw-r--r--app-containers/podman/podman-9999.ebuild4
6 files changed, 11 insertions, 11 deletions
diff --git a/app-containers/podman/podman-4.9.4.ebuild b/app-containers/podman/podman-4.9.4.ebuild
index ea2bd34e2507..f47814bad560 100644
--- a/app-containers/podman/podman-4.9.4.ebuild
+++ b/app-containers/podman/podman-4.9.4.ebuild
@@ -114,7 +114,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install install.completions $(usev wrapper install.docker-full)
+ emake DESTDIR="${D}" SELINUXOPT= install install.completions $(usev wrapper install.docker-full)
insinto /etc/cni/net.d
doins cni/87-podman-bridge.conflist
diff --git a/app-containers/podman/podman-5.0.2.ebuild b/app-containers/podman/podman-5.0.2.ebuild
index 738613b007dc..4ac692ff576c 100644
--- a/app-containers/podman/podman-5.0.2.ebuild
+++ b/app-containers/podman/podman-5.0.2.ebuild
@@ -102,12 +102,12 @@ src_compile() {
fi
# BUILD_SECCOMP is used in the patch to toggle seccomp
- emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" BUILD_SECCOMP="$(usex seccomp)" \
+ emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" BUILD_SECCOMP="$(usex seccomp)" SELINUXOPT= \
all $(usev wrapper docker-docs)
}
src_install() {
- emake DESTDIR="${D}" install install.completions $(usev wrapper install.docker-full)
+ emake DESTDIR="${D}" SELINUXOPT= install install.completions $(usev wrapper install.docker-full)
if use !systemd; then
newconfd "${FILESDIR}"/podman-5.0.0_rc4.confd podman
diff --git a/app-containers/podman/podman-5.0.3.ebuild b/app-containers/podman/podman-5.0.3.ebuild
index 738613b007dc..4ac692ff576c 100644
--- a/app-containers/podman/podman-5.0.3.ebuild
+++ b/app-containers/podman/podman-5.0.3.ebuild
@@ -102,12 +102,12 @@ src_compile() {
fi
# BUILD_SECCOMP is used in the patch to toggle seccomp
- emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" BUILD_SECCOMP="$(usex seccomp)" \
+ emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" BUILD_SECCOMP="$(usex seccomp)" SELINUXOPT= \
all $(usev wrapper docker-docs)
}
src_install() {
- emake DESTDIR="${D}" install install.completions $(usev wrapper install.docker-full)
+ emake DESTDIR="${D}" SELINUXOPT= install install.completions $(usev wrapper install.docker-full)
if use !systemd; then
newconfd "${FILESDIR}"/podman-5.0.0_rc4.confd podman
diff --git a/app-containers/podman/podman-5.1.1.ebuild b/app-containers/podman/podman-5.1.1.ebuild
index fd1d527b4b94..1deb45b19629 100644
--- a/app-containers/podman/podman-5.1.1.ebuild
+++ b/app-containers/podman/podman-5.1.1.ebuild
@@ -114,12 +114,12 @@ src_compile() {
tc-export PKG_CONFIG
fi
- emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" EXTRA_BUILDTAGS="$(usev seccomp)" \
+ emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" EXTRA_BUILDTAGS="$(usev seccomp)" SELINUXOPT= \
all $(usev wrapper docker-docs)
}
src_install() {
- emake DESTDIR="${D}" install install.completions $(usev wrapper install.docker-full)
+ emake DESTDIR="${D}" SELINUXOPT= install install.completions $(usev wrapper install.docker-full)
if use !systemd; then
newconfd "${FILESDIR}"/podman-5.0.0_rc4.confd podman
diff --git a/app-containers/podman/podman-5.2.4.ebuild b/app-containers/podman/podman-5.2.4.ebuild
index d467fd8b499a..91caafc19598 100644
--- a/app-containers/podman/podman-5.2.4.ebuild
+++ b/app-containers/podman/podman-5.2.4.ebuild
@@ -114,12 +114,12 @@ src_compile() {
tc-export PKG_CONFIG
fi
- emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" EXTRA_BUILDTAGS="$(usev seccomp)" \
+ emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" EXTRA_BUILDTAGS="$(usev seccomp)" SELINUXOPT= \
all $(usev wrapper docker-docs)
}
src_install() {
- emake DESTDIR="${D}" install install.completions $(usev wrapper install.docker-full)
+ emake DESTDIR="${D}" SELINUXOPT= install install.completions $(usev wrapper install.docker-full)
if use !systemd; then
newconfd "${FILESDIR}"/podman-5.0.0_rc4.confd podman
diff --git a/app-containers/podman/podman-9999.ebuild b/app-containers/podman/podman-9999.ebuild
index fd1d527b4b94..1deb45b19629 100644
--- a/app-containers/podman/podman-9999.ebuild
+++ b/app-containers/podman/podman-9999.ebuild
@@ -114,12 +114,12 @@ src_compile() {
tc-export PKG_CONFIG
fi
- emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" EXTRA_BUILDTAGS="$(usev seccomp)" \
+ emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" EXTRA_BUILDTAGS="$(usev seccomp)" SELINUXOPT= \
all $(usev wrapper docker-docs)
}
src_install() {
- emake DESTDIR="${D}" install install.completions $(usev wrapper install.docker-full)
+ emake DESTDIR="${D}" SELINUXOPT= install install.completions $(usev wrapper install.docker-full)
if use !systemd; then
newconfd "${FILESDIR}"/podman-5.0.0_rc4.confd podman