summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 07:48:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 08:34:01 +0200
commita7746527d5db60c7b7f8d5810b9edffa94982544 (patch)
treeae63767d5943eb94431ae18ccf7acf99dd96bf0d
parentnet-mail/mu: drop 1.7.12, 1.7.13 (diff)
downloadgentoo-a7746527d5db60c7b7f8d5810b9edffa94982544.tar.gz
gentoo-a7746527d5db60c7b7f8d5810b9edffa94982544.tar.bz2
gentoo-a7746527d5db60c7b7f8d5810b9edffa94982544.zip
dev-python/keyring: Bump to 23.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-23.5.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 0f4c66af10c2..b53e88d0a9f1 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1 +1,2 @@
DIST keyring-23.5.0.tar.gz 44586 BLAKE2B 70179f8353147679f03c888b1af00d2461264e7a7062eb7b1372615ae883f43352999ce57e24f3378ac66d5e74a81df66702bf380eb32d6d3554777e9ca63dfe SHA512 639d1cdece5dac854053818f3a4751b30fb9f13a2b3abb0090ba0cb519b50604858673678fe6205c2ec10be863e5f3d63cc7891424beabe2482d35b820a60da1
+DIST keyring-23.5.1.gh.tar.gz 44938 BLAKE2B 65c03e58ae8de844c1ed58486fd6348a1c7063025d92f9857c972cb3b2f29f4726dd03d25ff04329170719478ec5334f922556ef8598416d0ee07af6fb23c167 SHA512 521dd393221287840a5e9d22e94714d88ebb3ac26e87a72dae4958b7d63900cc445bdd087c2192353cdcd72b380d17838e93c4d9e1012f13e026ea27def11f38
diff --git a/dev-python/keyring/keyring-23.5.1.ebuild b/dev-python/keyring/keyring-23.5.1.ebuild
new file mode 100644
index 000000000000..2166b7749410
--- /dev/null
+++ b/dev-python/keyring/keyring-23.5.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="
+ https://github.com/jaraco/keyring/
+ https://pypi.org/project/keyring/
+"
+SRC_URI="
+ https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/secretstorage-3.2[${PYTHON_USEDEP}]
+ >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/jaraco-packaging \
+ dev-python/rst-linker
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+)
+
+EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+)
+
+src_prepare() {
+ # remove jaraco.tidelift dependency from docs, quite useless
+ sed -e '/tidelift/d' -i docs/conf.py docs/index.rst || die
+
+ distutils-r1_src_prepare
+}