summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-22 10:34:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-22 10:55:46 +0100
commita97111edf2940ad7d52b113afb79a69ed69dfdaa (patch)
treed9890d008cdc3ce88b7102eac61cbc1f08386c3e
parentdev-python/qtconsole: Bump to 5.0.2 (diff)
downloadgentoo-a97111edf2940ad7d52b113afb79a69ed69dfdaa.tar.gz
gentoo-a97111edf2940ad7d52b113afb79a69ed69dfdaa.tar.bz2
gentoo-a97111edf2940ad7d52b113afb79a69ed69dfdaa.zip
dev-python/nbformat: Fix installing package data
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbformat/files/nbformat-5.1.2-package-data.patch50
-rw-r--r--dev-python/nbformat/nbformat-5.1.2-r1.ebuild (renamed from dev-python/nbformat/nbformat-5.1.2.ebuild)6
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/nbformat/files/nbformat-5.1.2-package-data.patch b/dev-python/nbformat/files/nbformat-5.1.2-package-data.patch
new file mode 100644
index 000000000000..4fd1de2a942b
--- /dev/null
+++ b/dev-python/nbformat/files/nbformat-5.1.2-package-data.patch
@@ -0,0 +1,50 @@
+From 6dc17e79be58c3cce66256eec2a565692cf95809 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 22 Jan 2021 10:16:24 +0100
+Subject: [PATCH] Fix installing package_data when --build-base is set
+
+Fix package_data declarations in setup.py to associate every set
+of files with its bottommost package. This is necessary for the 'build'
+command to install files correctly when --build-base is passed
+explicitly. The all-files-for-top-package approach seems to work only
+incidentally.
+
+To reproduce the problem, try:
+
+ setup.py build --build-base=build2
+
+and note that none of the data files were installed.
+---
+ setup.py | 16 +++++++++++-----
+ 1 file changed, 11 insertions(+), 5 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 22305d3..0a6aa45 100644
+--- a/setup.py
++++ b/setup.py
+@@ -34,11 +34,17 @@ for d, _, _ in os.walk(pjoin(here, name)):
+ packages.append(d[len(here)+1:].replace(os.path.sep, '.'))
+
+ package_data = {
+- 'nbformat' : [
+- 'corpus/*.txt'
+- 'tests/*.ipynb',
+- 'v3/nbformat.v3*.schema.json',
+- 'v4/nbformat.v4*.schema.json',
++ 'nbformat.corpus' : [
++ '*.txt',
++ ],
++ 'nbformat.tests' : [
++ '*.ipynb',
++ ],
++ 'nbformat.v3' : [
++ 'nbformat.v3*.schema.json',
++ ],
++ 'nbformat.v4' : [
++ 'nbformat.v4*.schema.json',
+ ],
+ }
+
+--
+2.30.0
+
diff --git a/dev-python/nbformat/nbformat-5.1.2.ebuild b/dev-python/nbformat/nbformat-5.1.2-r1.ebuild
index 6991991c0a60..2444649ad3e1 100644
--- a/dev-python/nbformat/nbformat-5.1.2.ebuild
+++ b/dev-python/nbformat/nbformat-5.1.2-r1.ebuild
@@ -26,13 +26,17 @@ RDEPEND="
>=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
dev-python/jupyter_core[${PYTHON_USEDEP}]
"
-DEPEND="
+BDEPEND="
test? (
dev-python/fastjsonschema[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
)
"
+PATCHES=(
+ "${FILESDIR}"/nbformat-5.1.2-package-data.patch
+)
+
distutils_enable_sphinx docs \
dev-python/numpydoc
distutils_enable_tests pytest