summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-10-03 23:04:42 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-10-03 23:06:33 +0200
commitaec6872c7e5263c6f41c6334628125ab53be63a1 (patch)
tree3f0087024c7e78b1d04dd8fe586d64aa25c687f0
parentnet-proxy/haproxy: Version bump (1.8.14) (diff)
downloadgentoo-aec6872c7e5263c6f41c6334628125ab53be63a1.tar.gz
gentoo-aec6872c7e5263c6f41c6334628125ab53be63a1.tar.bz2
gentoo-aec6872c7e5263c6f41c6334628125ab53be63a1.zip
dev-python/pyftpdlib: fix tests with TZ=GMT
Also: * pytest-relaxed is not loaded by default since commit ac9e67fa461c484fd751040bb6b58c258b6d601c. * make tests more verbose. Closes: https://bugs.gentoo.org/666623 Signed-off-by: Louis Sautier <sbraz@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
index b34a8629054b..1633ef26aff6 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -64,9 +64,10 @@ python_test() {
test_nlst
)
skipped_tests=${skipped_tests[@]/%/ or}
- # Don't load the relaxed plugin, see https://bugs.gentoo.org/661082
- py.test --ignore ${PN}/test/test_misc.py -k "not (${skipped_tests% or})" \
- -p no:relaxed || die "Tests failed with ${EPYTHON}"
+ # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
+ TZ=UTC+1 pytest -vv \
+ --ignore ${PN}/test/test_misc.py -k "not (${skipped_tests% or})" \
+ || die "Tests failed with ${EPYTHON}"
}
python_install_all() {