summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-03 08:43:37 +0000
committerSam James <sam@gentoo.org>2020-12-03 08:43:44 +0000
commitb5f1f67cfd68452cbe5557b082b087175998361b (patch)
tree1edb0bb9cd6e30736d7a5418411bde881c297e73
parentdev-python/progressbar2: bump to 3.53.1 (diff)
downloadgentoo-b5f1f67cfd68452cbe5557b082b087175998361b.tar.gz
gentoo-b5f1f67cfd68452cbe5557b082b087175998361b.tar.bz2
gentoo-b5f1f67cfd68452cbe5557b082b087175998361b.zip
dev-python/python-utils: bump to 2.4.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-2.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 187109d96119..0b9fd897533a 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1 +1,2 @@
DIST python-utils-2.3.0.tar.gz 19384 BLAKE2B 1746deadc8dbaf49a6499fe9c79d25c2b5cfea68e2d1b7ab6f88aa72807eedcdb338058e24a7822c6360dea36f1a044145572443c57f43f4cfed765a76e48f0b SHA512 482ccf9c635a0cbe603b69488a364d9033f8b7fada279d901725b5bf91ac13b1cd4a6b7e8d5834a9355d97d8b0803397d5e13da2b7ba72f8d8e2f7f39fee027a
+DIST python-utils-2.4.0.tar.gz 22230 BLAKE2B 1c144f62a009a2470ec43341283048842cba61f1b677e8b1d197d3ef39dd1d890b364e63ed8da0b30ad5560d335ab0eb2dfc329ff6dfea86c0f64e909de730b9 SHA512 bfad0ef30383df634b89bb2206a00e45434eff9fee9ba0eeab99361bacfb56f3fb420019608b639713a7e8777870de75becb1d7b48aa09c582df27f9ebe8c512
diff --git a/dev-python/python-utils/python-utils-2.4.0.ebuild b/dev-python/python-utils/python-utils-2.4.0.ebuild
new file mode 100644
index 000000000000..880245a0fc3c
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
+ find . -name '*.pyc' -exec rm -f {} \; || die "Cleaning *.pyc failed"
+ sed -i -e '/--cov/d' -e '/--pep8/d' -e '/--flakes/d' pytest.ini || die
+ sed -i -e 's/+ pytest-runner//' setup.py || die
+ distutils-r1_python_prepare_all
+}