summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-14 23:43:10 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-15 04:01:30 -0400
commitc52f4c6b816c35fe489e83b85dc8a0c925644e47 (patch)
tree177caa78480dea76a8ab83b6bbc4a2dc1b42d1e9
parentmail-mta/courier: add 1.3.9 (diff)
downloadgentoo-c52f4c6b816c35fe489e83b85dc8a0c925644e47.tar.gz
gentoo-c52f4c6b816c35fe489e83b85dc8a0c925644e47.tar.bz2
gentoo-c52f4c6b816c35fe489e83b85dc8a0c925644e47.zip
sci-libs/fftw: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
-rw-r--r--sci-libs/fftw/fftw-3.3.10.ebuild12
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild12
2 files changed, 16 insertions, 8 deletions
diff --git a/sci-libs/fftw/fftw-3.3.10.ebuild b/sci-libs/fftw/fftw-3.3.10.ebuild
index 213b53606d55..3e3cdf42bc76 100644
--- a/sci-libs/fftw/fftw-3.3.10.ebuild
+++ b/sci-libs/fftw/fftw-3.3.10.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
FORTRAN_NEEDED=fortran
-inherit fortran-2 multibuild multilib-minimal toolchain-funcs
+inherit fortran-2 libtool multibuild multilib-minimal toolchain-funcs
DESCRIPTION="Fast C library for the Discrete Fourier Transform"
HOMEPAGE="https://www.fftw.org/"
@@ -50,8 +50,12 @@ pkg_setup() {
src_prepare() {
default
- # fix info file for category directory
- [[ ${PV} == *9999 ]] && eautoreconf
+ if [[ ${PV} == *9999 ]]; then
+ # fix info file for category directory
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
multilib_src_configure() {
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
index f3fa7dd693b0..f1bc2d876ad8 100644
--- a/sci-libs/fftw/fftw-9999.ebuild
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
FORTRAN_NEEDED=fortran
-inherit fortran-2 multibuild multilib-minimal toolchain-funcs
+inherit fortran-2 libtool multibuild multilib-minimal toolchain-funcs
DESCRIPTION="Fast C library for the Discrete Fourier Transform"
HOMEPAGE="https://www.fftw.org/"
@@ -50,8 +50,12 @@ pkg_setup() {
src_prepare() {
default
- # fix info file for category directory
- [[ ${PV} == *9999 ]] && eautoreconf
+ if [[ ${PV} == *9999 ]]; then
+ # fix info file for category directory
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
multilib_src_configure() {