summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-11-22 07:29:08 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-11-22 07:29:08 +0200
commitc6fd52a0135b91fdf57b38e1215adab54c903188 (patch)
tree3f8a5bdcdcc1d7d6c0079be79d943253b07b3aaf
parentapp-admin/linode-cli: add 5.55.0 (diff)
downloadgentoo-c6fd52a0135b91fdf57b38e1215adab54c903188.tar.gz
gentoo-c6fd52a0135b91fdf57b38e1215adab54c903188.tar.bz2
gentoo-c6fd52a0135b91fdf57b38e1215adab54c903188.zip
app-admin/linode-cli: drop 5.52.0, 5.53.1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--app-admin/linode-cli/Manifest2
-rw-r--r--app-admin/linode-cli/linode-cli-5.52.0.ebuild45
-rw-r--r--app-admin/linode-cli/linode-cli-5.53.1.ebuild45
3 files changed, 0 insertions, 92 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
index 77d68ba3f635..71d3de47e385 100644
--- a/app-admin/linode-cli/Manifest
+++ b/app-admin/linode-cli/Manifest
@@ -1,4 +1,2 @@
-DIST linode_cli-5.52.0.tar.gz 160729 BLAKE2B dc0a4c30dcaab3c07c64aa519786f461a79e6f532ebfcc9917e6654b6a8bd32b2cfa2f323036d3870555b7b91620121264877a0fbae4b1bc2a71e885558bb261 SHA512 26c774e0936e16f391c5b028ffc91370d6401e85e92f08ce2e3b2435be3a8230d0d8edd3904ff0514c76b135a3ff88fae27e5e452d0aae534b0deb6f9fc8a2ff
-DIST linode_cli-5.53.1.tar.gz 154260 BLAKE2B c2c9d00f0686bcd4d083974c7c2e167963a6af2d04c244c854937e2301de6df62cf82d872aa53f01150bb657895bccedba1df2ce4d6d091ce27c7abd599d2250 SHA512 ea7b8cf42f041deca2e745d4e8113beb2c46a3a79e5a56b57a24379581eca793e2f3e0d0b5821e3644450eb4da207c3884098ad33e9ec62775657a625ed4a849
DIST linode_cli-5.54.0.tar.gz 153961 BLAKE2B ae147c7c29532d53e8230e8374acb5727791f07f3177720637d7b23d1169821b2a65975b6e22f45bb53f69d241525ecb081a18f854d3d904da9de406f27f146f SHA512 7cad0e899ebced5c27923f4b8ea6fc4c854f90f7925ff5e8e010565ec51f20c75976a0efacfebceb78c4befa0e64ea0a2c896bb82f541903413fe96c8b0c68e1
DIST linode_cli-5.55.0.tar.gz 159746 BLAKE2B 1ef914ec316bebb40961f075c528d8311c21030bcc643e45e18e187cce8d52f2a79629be7482778e5f0061c3db143685b5899e7e0c563f0565bbad3390dc3783 SHA512 37b88fbdbc66a6057a3b50379928d7f0547136aa8d068109b2dd3d2c6969698598a26c84b1f7494952795dc52a7ab05e2240680d86e88c85007df1e53445052d
diff --git a/app-admin/linode-cli/linode-cli-5.52.0.ebuild b/app-admin/linode-cli/linode-cli-5.52.0.ebuild
deleted file mode 100644
index 21d1ca44d811..000000000000
--- a/app-admin/linode-cli/linode-cli-5.52.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi shell-completion
-
-DESCRIPTION="Official command-line interface for interacting with the Linode API"
-HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# Tests require network, a linode account and an API key.
-# WARNING: tests will incur costs and will wipe the account.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/boto3[${PYTHON_USEDEP}]
- >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
- dev-python/openapi3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- <dev-python/urllib3-3[${PYTHON_USEDEP}]
-"
-
-python_install_all() {
- distutils-r1_python_install_all
-
- PYTHONPATH=. ${EPYTHON} linodecli completion bash > "${T}/${PN}".bash || die
- PYTHONPATH=. ${EPYTHON} linodecli completion fish > "${T}/${PN}".fish || die
-
- newbashcomp "${T}/${PN}".bash ${PN}
- newfishcomp "${T}/${PN}".fish ${PN}
-
- dosym ${PN} "$(get_bashcompdir)"/linode
- dosym ${PN} "$(get_bashcompdir)"/lin
- dosym ${PN} "$(get_fishcompdir)"/linode
- dosym ${PN} "$(get_fishcompdir)"/lin
-}
diff --git a/app-admin/linode-cli/linode-cli-5.53.1.ebuild b/app-admin/linode-cli/linode-cli-5.53.1.ebuild
deleted file mode 100644
index 21d1ca44d811..000000000000
--- a/app-admin/linode-cli/linode-cli-5.53.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi shell-completion
-
-DESCRIPTION="Official command-line interface for interacting with the Linode API"
-HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# Tests require network, a linode account and an API key.
-# WARNING: tests will incur costs and will wipe the account.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/boto3[${PYTHON_USEDEP}]
- >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
- dev-python/openapi3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- <dev-python/urllib3-3[${PYTHON_USEDEP}]
-"
-
-python_install_all() {
- distutils-r1_python_install_all
-
- PYTHONPATH=. ${EPYTHON} linodecli completion bash > "${T}/${PN}".bash || die
- PYTHONPATH=. ${EPYTHON} linodecli completion fish > "${T}/${PN}".fish || die
-
- newbashcomp "${T}/${PN}".bash ${PN}
- newfishcomp "${T}/${PN}".fish ${PN}
-
- dosym ${PN} "$(get_bashcompdir)"/linode
- dosym ${PN} "$(get_bashcompdir)"/lin
- dosym ${PN} "$(get_fishcompdir)"/linode
- dosym ${PN} "$(get_fishcompdir)"/lin
-}