summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-13 12:36:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-13 15:19:16 +0200
commitcff95a2a98a0f42d8449aad46281c9cf75e4145d (patch)
tree11cea69ad69233042fce34f6c29c2fceb4c3aae6
parentsys-apps/kmscon: drop 8_p20180906-r2, 8_p20220214, 8_p20220214-r1 (diff)
downloadgentoo-cff95a2a98a0f42d8449aad46281c9cf75e4145d.tar.gz
gentoo-cff95a2a98a0f42d8449aad46281c9cf75e4145d.tar.bz2
gentoo-cff95a2a98a0f42d8449aad46281c9cf75e4145d.zip
kde-frameworks/frameworkintegration: 5.98.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.98.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 646d4c3f68f2..a1e4ee0f680d 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.96.0.tar.xz 1759604 BLAKE2B 24d4806432487e35e01645da97195f700e086c68c6d2f39e7e5e86d00f10a982224fff2fa2eb7d7808fadad4d7524fd2318f67f8d47759e2533a261aa8589470 SHA512 cdc521ff7ba5d3c37d239fb7575a8c1e5b66b1bcba9e315da857b3ddd25b9a7cabc3dc0338186b23b9606badef7c7153c117b92618b626eb54b95c540cc2e680
DIST frameworkintegration-5.97.0.tar.xz 1759588 BLAKE2B 2165bedee7866dfe2b08313af0a77339a7f7a1ec3ba77d30dcc5346af6023786a34a0d14499ab50923d5989fd94187941ca26442e04340c327bdcc637ab31210 SHA512 5b6a4f562183c4cda5c068786b14db22508af0ea535cf6a03e5502834196a6393a43def590fea1ee8562cb7f3bbc2c69722d459225b0128a593f32ba486a5e51
+DIST frameworkintegration-5.98.0.tar.xz 1759612 BLAKE2B 8b70ce428822918275ce68ff466940ef15332727a7fd2486b44d257547974b50c72a7f2ae0181eacfe7bf893d325eb33abaa15007a17a92651e6de7a8e6417e1 SHA512 bbf7e20615df6f7613c271da683bd3065df78bbd1231bdbf96991bb674923b40586013bcc8c6191f6b2f4ed2547dbf26e0c4f48eeccef233768ce4c89d00d2e5
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.98.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.98.0.ebuild
new file mode 100644
index 000000000000..e4e34fce95e5
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.98.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}