summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-06 08:40:54 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-06 09:22:30 +0200
commitd2464384847f1a4e50411db186ca62c190c4f29c (patch)
tree4e873c1fbdaf0bf2eab022353ce4d366b3855c4f
parentdev-python/towncrier: Bump to 21.3.0 (diff)
downloadgentoo-d2464384847f1a4e50411db186ca62c190c4f29c.tar.gz
gentoo-d2464384847f1a4e50411db186ca62c190c4f29c.tar.bz2
gentoo-d2464384847f1a4e50411db186ca62c190c4f29c.zip
dev-python/botocore: Bump to 1.20.45
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.45.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 140705fd37a5..6dca42cf6bc4 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.20.41.tar.gz 7572739 BLAKE2B 2fde8a64fd04acd698b91e222934ba5338c
DIST botocore-1.20.42.tar.gz 7579571 BLAKE2B 26d4a2c9e2df7df92888e9f49dba3799ccf5c0d9745cb46fd6d3ff0f4b1ea7cd5faa3bd6e173d67ec052989fbc92e4d7d6cb298c9d7807b3eea6b4c5d9e1abc1 SHA512 447c0fd5aa9864dacbb132f451f260f9d3f83fe70444993283ae0845150c383e2ef9df20e8977705d86d2698b8d12189071a2c27cb0ee1e6358eb0619ee2173b
DIST botocore-1.20.43.tar.gz 7595391 BLAKE2B 78c7e146e2a5b204c5a4c0b6c0d8ea6ee8bdc36339698a671c90f529f74ce4e9314a901021fc7eeb93a8ad81d8442093478a365076175129a9924891dbfe34bd SHA512 2b575aed2748d5f4c8be593eb119f9453237c81a5fe53a5852a14f355626fa56111a5932ccf2825e28100414ea2ce5fd57b923e819296cf7eebe88a786bbf14a
DIST botocore-1.20.44.tar.gz 7596878 BLAKE2B 935d4ea1c5212d29566c3344761b00d2eb03e7588bd7805072926ecd41f0fa03cd91e25802dc63078190c49f1b8503545bd0b2a88d702c04a961d57a0022080f SHA512 eb7ae15bac4ae8ad516ebcd8166f65a809d7d02c11dde25b714f7bf673ecfeef9ea414ab4b53ac428ac948ee8b054666ba2f6c0a96e6d148ff46d94e6100350d
+DIST botocore-1.20.45.tar.gz 7597127 BLAKE2B 64023be1da8b10ab29110fe626ba641e9da48a47db663c2e17ed8f590b448d4fab07d66cbb68485cacaed556f27c48e12a8b2d7aa6053fcff921e4776f8a9db8 SHA512 2a3f97e4f1046aa4df3a5da9d3722579dcea0937807d9115ec5480e243788a31c58d10e1b4e002cb43668adb75174d9351cbf6b52edc0a5970c7d4b10691b02c
diff --git a/dev-python/botocore/botocore-1.20.45.ebuild b/dev-python/botocore/botocore-1.20.45.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.45.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}