summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-15 05:02:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-15 05:49:33 +0100
commitdab9e77ed0c76e3eddab46cf697bff5d9aa21cc6 (patch)
tree5f707976f561b068214a908de4d31bcd0233cee8
parentdev-python/botocore: Bump to 1.34.63 (diff)
downloadgentoo-dab9e77ed0c76e3eddab46cf697bff5d9aa21cc6.tar.gz
gentoo-dab9e77ed0c76e3eddab46cf697bff5d9aa21cc6.tar.bz2
gentoo-dab9e77ed0c76e3eddab46cf697bff5d9aa21cc6.zip
dev-python/boto3: Bump to 1.34.63
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.63.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index d73325be9499..2ae9a23c2de2 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.34.59.gh.tar.gz 782060 BLAKE2B d46f20f101f36380a17cb5c1bd511adde1b9
DIST boto3-1.34.60.gh.tar.gz 782539 BLAKE2B d0fa63256b967b9a93139d4ee41e5892187cc54671b5a7c47b8e6900ac1b9ea7bae8d8b38a0f18432813a6085e2773b7c7b8686e9d5d7d13465b8547f0bb9e30 SHA512 f60ae6664ce19bdddb552d72c2f0699d8bd771e23f164e29f5c3c7869680528a6e9b8d678c7c0359dbe25c3e20077a7cf45efd01f207340dbe0ee6198e08a4c5
DIST boto3-1.34.61.gh.tar.gz 782749 BLAKE2B 058b8389a57c1e652789ddf9ce83f754ecd94e90f292f3d9ed70cc3456a547578591fa7d908838296186707074b874ac5898e5960022cfd3ecbac9e8cbefa8a0 SHA512 8b72e539def341676a928d346099b8076c21543606a0a02050aa792c95a898c0b00edeccc2c0eadf241071c78b859b4240b2e40e32c3a16dbbc4cbbfff89e9cd
DIST boto3-1.34.62.gh.tar.gz 783049 BLAKE2B ad4272a4dfc02305e734c007d3e24f2dff8fd6fee20025b5edf76797e8d691e81f827e4e1d5357669ca86f5dbf41c5c2e09be16ac391153c9a158c292a79089a SHA512 717e0e5d59efaa6d2443b30f6f51f5c00c5f573219f5b4018d0b9142db04559c5eaf1fd27bc9f8875b0c7892e71532a2b090bc5b552dfb4852d253377437403b
+DIST boto3-1.34.63.gh.tar.gz 783934 BLAKE2B aa74cf675df14b64360c3238c85ca04caa6cab9915ac092c19ca2649aca62d210d4f142b82ff33b39c87f5f1bc8d4db18332d7f7e2cde49b67c5c61d5d165fd0 SHA512 cbb629ab7760936584bb40a3cc417f6c5392715055d64fb9a08ac8cc45f3147f3536881a74984e94b405c234f102de613ec5bd6ccfd5fd483cae2f2e22ed0abc
diff --git a/dev-python/boto3/boto3-1.34.63.ebuild b/dev-python/boto3/boto3-1.34.63.ebuild
new file mode 100644
index 000000000000..b64e7191fd19
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.63.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}