summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-15 07:53:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-16 20:21:10 +0200
commite3cff0a513ecf019311791d50cee5edac2d7da6e (patch)
treeb257ad73fcf65f0bdcd5b54b734f21528586e82f
parentdev-python/nose-random: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-e3cff0a513ecf019311791d50cee5edac2d7da6e.tar.gz
gentoo-e3cff0a513ecf019311791d50cee5edac2d7da6e.tar.bz2
gentoo-e3cff0a513ecf019311791d50cee5edac2d7da6e.zip
dev-python/manuel: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/748339 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/manuel/manuel-1.9.0.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/manuel/manuel-1.9.0.ebuild b/dev-python/manuel/manuel-1.9.0.ebuild
index f7f535aa438a..0516848a17be 100644
--- a/dev-python/manuel/manuel-1.9.0.ebuild
+++ b/dev-python/manuel/manuel-1.9.0.ebuild
@@ -3,7 +3,8 @@
EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -18,10 +19,6 @@ KEYWORDS="amd64 x86"
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
# Required to run tests
DISTUTILS_IN_SOURCE_BUILD=1