summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-18 10:46:58 +0100
committerSam James <sam@gentoo.org>2023-08-18 10:46:58 +0100
commite737e7a50811b3afdada71a381751eaec0908d5c (patch)
treed91fe4d834e8e98c86c05fa81759bff7de9fe6bd
parentsys-cluster/galera: add 26.4.15 (diff)
downloadgentoo-e737e7a50811b3afdada71a381751eaec0908d5c.tar.gz
gentoo-e737e7a50811b3afdada71a381751eaec0908d5c.tar.bz2
gentoo-e737e7a50811b3afdada71a381751eaec0908d5c.zip
sys-cluster/galera: make SSL optional
I can see this being useful especially for either where links are over a VPN or similar and/or where new OpenSSL causes problems for people in future. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/galera/galera-26.4.15.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-cluster/galera/galera-26.4.15.ebuild b/sys-cluster/galera/galera-26.4.15.ebuild
index 0593b2770b14..8268ec426c17 100644
--- a/sys-cluster/galera/galera-26.4.15.ebuild
+++ b/sys-cluster/galera/galera-26.4.15.ebuild
@@ -16,11 +16,11 @@ S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="garbd test"
+IUSE="garbd test ssl"
RESTRICT="!test? ( test )"
RDEPEND="
- dev-libs/openssl:=
+ ssl? ( dev-libs/openssl:= )
dev-libs/boost:=
"
DEPEND="
@@ -42,6 +42,14 @@ src_prepare() {
fi
}
+src_configure() {
+ local mycmakeargs=(
+ -DGALERA_WITH_SSL=$(usex ssl)
+ )
+
+ cmake_src_configure
+}
+
src_install() {
dodoc scripts/packages/README scripts/packages/README-MySQL