summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2022-02-20 10:51:22 +0100
committerSam James <sam@gentoo.org>2022-02-20 23:11:40 +0000
commitf007a2b124b36813ad00db536aa082e433651c51 (patch)
tree847189209148278708c0c1050cc18e1424fae6d7
parentsci-libs/pdal: add pdal library (diff)
downloadgentoo-f007a2b124b36813ad00db536aa082e433651c51.tar.gz
gentoo-f007a2b124b36813ad00db536aa082e433651c51.tar.bz2
gentoo-f007a2b124b36813ad00db536aa082e433651c51.zip
sci-geosciences/qgis: add pdal for point clouds
Closes: https://bugs.gentoo.org/830003 Closes: https://github.com/gentoo/gentoo/pull/23526 Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-geosciences/qgis/metadata.xml1
-rw-r--r--sci-geosciences/qgis/qgis-3.22.4.ebuild4
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild6
-rw-r--r--sci-libs/pdal/metadata.xml12
-rw-r--r--sci-libs/pdal/pdal-2.3.0.ebuild6
5 files changed, 19 insertions, 10 deletions
diff --git a/sci-geosciences/qgis/metadata.xml b/sci-geosciences/qgis/metadata.xml
index a63b6aef6b2a..8d7ea9e307f6 100644
--- a/sci-geosciences/qgis/metadata.xml
+++ b/sci-geosciences/qgis/metadata.xml
@@ -21,6 +21,7 @@
<flag name="mapserver">Determines whether mapserver should be built</flag>
<flag name="netcdf">Enable MDAL support for GRIB and XMDF formats</flag>
<flag name="opencl">Enable OpenCL support</flag>
+ <flag name="pdal">Enable support for PDAL for point clouds via <pkg>sci-libs/pdal</pkg></flag>
<flag name="polar">Enable support for the polar coordinate system via <pkg>x11-libs/qwtpolar</pkg></flag>
<flag name="qml">Enable support Qml-based plugins using <pkg>dev-qt/qtdeclarative</pkg></flag>
<flag name="serial">Enable support for serial GPS using <pkg>dev-qt/qtserialport</pkg></flag>
diff --git a/sci-geosciences/qgis/qgis-3.22.4.ebuild b/sci-geosciences/qgis/qgis-3.22.4.ebuild
index 424d7ec8847e..12e8cd68f1e8 100644
--- a/sci-geosciences/qgis/qgis-3.22.4.ebuild
+++ b/sci-geosciences/qgis/qgis-3.22.4.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://www.qgis.org/"
LICENSE="GPL-2+ GPL-3+"
SLOT="0"
-IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml serial"
+IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle pdal polar postgres python qml serial"
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
@@ -66,6 +66,7 @@ COMMON_DEPEND="
dev-db/oracle-instantclient:=
sci-libs/gdal:=[oracle]
)
+ pdal? ( sci-libs/pdal:= )
polar? ( >=x11-libs/qwtpolar-1.1.1-r1[qt5(+)] )
postgres? ( dev-db/postgresql:= )
python? (
@@ -140,6 +141,7 @@ src_configure() {
-DUSE_OPENCL=$(usex opencl)
-DWITH_ORACLE=$(usex oracle)
-DWITH_QWTPOLAR=$(usex polar)
+ -DWITH_PDAL=$(usex pdal)
-DWITH_POSTGRESQL=$(usex postgres)
-DWITH_BINDINGS=$(usex python)
-DWITH_CUSTOM_WIDGETS=$(usex python)
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index af65e82db8df..12e8cd68f1e8 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,7 +21,7 @@ HOMEPAGE="https://www.qgis.org/"
LICENSE="GPL-2+ GPL-3+"
SLOT="0"
-IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml serial"
+IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle pdal polar postgres python qml serial"
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
@@ -66,6 +66,7 @@ COMMON_DEPEND="
dev-db/oracle-instantclient:=
sci-libs/gdal:=[oracle]
)
+ pdal? ( sci-libs/pdal:= )
polar? ( >=x11-libs/qwtpolar-1.1.1-r1[qt5(+)] )
postgres? ( dev-db/postgresql:= )
python? (
@@ -140,6 +141,7 @@ src_configure() {
-DUSE_OPENCL=$(usex opencl)
-DWITH_ORACLE=$(usex oracle)
-DWITH_QWTPOLAR=$(usex polar)
+ -DWITH_PDAL=$(usex pdal)
-DWITH_POSTGRESQL=$(usex postgres)
-DWITH_BINDINGS=$(usex python)
-DWITH_CUSTOM_WIDGETS=$(usex python)
diff --git a/sci-libs/pdal/metadata.xml b/sci-libs/pdal/metadata.xml
index 3be37e190bd4..e6a3eb2519dd 100644
--- a/sci-libs/pdal/metadata.xml
+++ b/sci-libs/pdal/metadata.xml
@@ -1,14 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>thomas.bettler@gmail.com</email>
+ <name>Thomas Bettler</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<maintainer type="project">
<email>sci-geosciences@gentoo.org</email>
<name>Gentoo Geosciences Project</name>
</maintainer>
- <maintainer type="person">
- <email>thomas.bettler@gmail.com</email>
- <name>Thomas Bettler</name>
- </maintainer>
<longdescription>
PDAL is a C++ library for translating and manipulating point cloud data.
It is very much like the GDAL library which handles raster and vector data.
diff --git a/sci-libs/pdal/pdal-2.3.0.ebuild b/sci-libs/pdal/pdal-2.3.0.ebuild
index ee1182834970..f85812782818 100644
--- a/sci-libs/pdal/pdal-2.3.0.ebuild
+++ b/sci-libs/pdal/pdal-2.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,8 +30,8 @@ DEPEND="
RDEPEND="${DEPEND}"
PATCHES=(
- ${FILESDIR}/${P}-fix_cmake_install_location.patch
- ${FILESDIR}/${P}-upgrade_cmake_min.patch
+ "${FILESDIR}"/${P}-fix_cmake_install_location.patch
+ "${FILESDIR}"/${P}-upgrade_cmake_min.patch
)
S="${WORKDIR}/PDAL-${PV}-src"