summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-01 11:48:28 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-01 11:50:03 -0400
commitff2c311988ad964bed25caf1d83cf1ff3eb9ba77 (patch)
tree16a1ee1159e1fb57fa2887dcc6b723cf813897fe
parentdev-libs/openssl: use BROOT to locate env. (diff)
downloadgentoo-ff2c311988ad964bed25caf1d83cf1ff3eb9ba77.tar.gz
gentoo-ff2c311988ad964bed25caf1d83cf1ff3eb9ba77.tar.bz2
gentoo-ff2c311988ad964bed25caf1d83cf1ff3eb9ba77.zip
net-libs/sofia-sip: Version bump to 1.13.8
Bug: https://bugs.gentoo.org/848870 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/sofia-sip/Manifest1
-rw-r--r--net-libs/sofia-sip/files/1.13.8-Fix-array-size.patch45
-rw-r--r--net-libs/sofia-sip/sofia-sip-1.13.8.ebuild48
3 files changed, 94 insertions, 0 deletions
diff --git a/net-libs/sofia-sip/Manifest b/net-libs/sofia-sip/Manifest
index 6302e6ab2d91..bedb883e4c10 100644
--- a/net-libs/sofia-sip/Manifest
+++ b/net-libs/sofia-sip/Manifest
@@ -1 +1,2 @@
DIST sofia-sip-1.12.11.tar.gz 2927808 BLAKE2B 2723aef491b5f85c047cc54a191fdd2ae63b23445f24b6ee9910af88e2daa684eded6e44cee50c3a52bec2901b5310f34c09e7cf4efce714210755046ceaecd7 SHA512 48bef0223ecf5a31267773c8e2491c1990b4419be67154e350cc9e5644a98e55409d635d7828824de3e0e1658caebe5b61e44d613615beb709ecbe8180be131c
+DIST sofia-sip-1.13.8.tar.gz 2551359 BLAKE2B 505d3cdac29b00589f63782c296b68f36ba9247ef87bcbda7b2765c0079aa2313ac72c0062ada5ba29e07faa892a991722c53468756ce8ef4cd385b90afda564 SHA512 f857eb9cf25d3306476bc6d0bda786385529021d498cf0c2c779cdbae31295af4ed59a67fb0c882b09bac738623d273a94ebbda360c7a2b3d7da140852ccc6fa
diff --git a/net-libs/sofia-sip/files/1.13.8-Fix-array-size.patch b/net-libs/sofia-sip/files/1.13.8-Fix-array-size.patch
new file mode 100644
index 000000000000..1473b18c61a5
--- /dev/null
+++ b/net-libs/sofia-sip/files/1.13.8-Fix-array-size.patch
@@ -0,0 +1,45 @@
+https://github.com/freeswitch/sofia-sip/pull/134
+
+From 17da7c45937cf0f66ca6a49a5661519443ebf8a7 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Wed, 1 Jun 2022 11:32:38 -0400
+Subject: [PATCH] Fix array size
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+check_sres_sip.c: In function ‘resolver_setup’:
+check_sres_sip.c:113:19: warning: array subscript 2 is above array bounds of ‘su_addrinfo_t[2]’ {aka ‘struct addrinfo[2]’} [-Warray-bounds]
+ 113 | hint_udp_tcp_tls[2].ai_protocol = TPPROTO_TLS;
+ | ~~~~~~~~~~~~~~~~^~~
+check_sres_sip.c:69:22: note: while referencing ‘hint_udp_tcp_tls’
+ 69 | static su_addrinfo_t hint_udp_tcp_tls[2];
+ | ^~~~~~~~~~~~~~~~
+check_sres_sip.c:114:19: warning: array subscript 2 is above array bounds of ‘su_addrinfo_t[2]’ {aka ‘struct addrinfo[2]’} [-Warray-bounds]
+ 114 | hint_udp_tcp_tls[2].ai_next = NULL;
+ | ~~~~~~~~~~~~~~~~^~~
+check_sres_sip.c:69:22: note: while referencing ‘hint_udp_tcp_tls’
+ 69 | static su_addrinfo_t hint_udp_tcp_tls[2];
+ | ^~~~~~~~~~~~~~~~
+
+Fixes: https://github.com/freeswitch/sofia-sip/issues/89
+---
+ libsofia-sip-ua/sresolv/check_sres_sip.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libsofia-sip-ua/sresolv/check_sres_sip.c b/libsofia-sip-ua/sresolv/check_sres_sip.c
+index ea392f0..e6c9642 100644
+--- a/libsofia-sip-ua/sresolv/check_sres_sip.c
++++ b/libsofia-sip-ua/sresolv/check_sres_sip.c
+@@ -66,7 +66,7 @@ struct context {
+ } x[1];
+
+ static su_addrinfo_t hint_udp_tcp[2];
+-static su_addrinfo_t hint_udp_tcp_tls[2];
++static su_addrinfo_t hint_udp_tcp_tls[3];
+ static su_addrinfo_t hint_udp_tcp_ip4[2];
+ static su_addrinfo_t hint_tls[1];
+ static su_addrinfo_t hint_tls_udp_tcp[1];
+--
+2.35.1
+
diff --git a/net-libs/sofia-sip/sofia-sip-1.13.8.ebuild b/net-libs/sofia-sip/sofia-sip-1.13.8.ebuild
new file mode 100644
index 000000000000..640a845a0cea
--- /dev/null
+++ b/net-libs/sofia-sip/sofia-sip-1.13.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="RFC3261 compliant SIP User-Agent library"
+HOMEPAGE="https://github.com/freeswitch/sofia-sip"
+SRC_URI="https://github.com/freeswitch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ BSD public-domain" # See COPYRIGHT
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ ssl? (
+ dev-libs/openssl:0=
+ )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-Fix-array-size.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+ dodoc RELEASE
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}