summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2018-03-31 04:48:54 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-04 23:09:32 +0200
commit8fbdb72214f4e64288c4abe4b4bc6fb9eee760a7 (patch)
tree8c557885d0fdecb125b741867f6c8b7def752edb /app-accessibility
parentdev-libs/libatomic_ops: Fix building with GCC-7 (diff)
downloadgentoo-8fbdb72214f4e64288c4abe4b4bc6fb9eee760a7.tar.gz
gentoo-8fbdb72214f4e64288c4abe4b4bc6fb9eee760a7.tar.bz2
gentoo-8fbdb72214f4e64288c4abe4b4bc6fb9eee760a7.zip
app-accessibility/epos: Fix building with GCC-7
Bug: https://bugs.gentoo.org/638596 Closes: https://bugs.gentoo.org/638596 Closes: https://github.com/gentoo/gentoo/pull/7760 Package-Manager: Portage-2.3.16, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7760
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/epos/epos-2.5.37-r2.ebuild1
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc7.patch22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-accessibility/epos/epos-2.5.37-r2.ebuild b/app-accessibility/epos/epos-2.5.37-r2.ebuild
index 65a83ff55fef..216717c781b9 100644
--- a/app-accessibility/epos/epos-2.5.37-r2.ebuild
+++ b/app-accessibility/epos/epos-2.5.37-r2.ebuild
@@ -23,6 +23,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.5.37-gcc45.patch
"${FILESDIR}"/${PN}-2.5.37-gcc47.patch
"${FILESDIR}"/${PN}-2.5.37-disable-tests.patch
+ "${FILESDIR}"/${PN}-2.5.37-gcc7.patch
)
src_prepare() {
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc7.patch b/app-accessibility/epos/files/epos-2.5.37-gcc7.patch
new file mode 100644
index 000000000000..6c889a662c2a
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc7.patch
@@ -0,0 +1,22 @@
+Bug: https://bugs.gentoo.org/638596
+
+--- a/src/nnet/matrix.cc
++++ b/src/nnet/matrix.cc
+@@ -63,7 +63,7 @@
+ template<class T> void CMatrix<T>::multiplyByTransponed (const CMatrix &y, CMatrix &retval)
+ {
+ int i,j,k;
+- assert (cols == y.cols);
++ this->assert (cols == y.cols);
+ if (cols != y.cols) { retval.Realloc (0,0); return; }
+
+ T sum;
+@@ -80,7 +80,7 @@
+ template<class T> void CMatrix<T>::transponedMultiply (const CMatrix &y, CMatrix &retval)
+ {
+ int i,j,k;
+- assert (rows == y.rows);
++ this->assert (rows == y.rows);
+ if (rows != y.rows) { retval.Realloc (0,0); return; }
+
+ T sum;