summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-09-13 11:36:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-09-13 11:36:20 -0500
commita93e8152ea03abae6a8040546390ac803da75435 (patch)
treef5d455596425fbcf1f60c6db613efdf62f085bf9 /app-admin/ansible/ansible-6.3.0.ebuild
parentapp-admin/ansible-core: add 2.12.9, 2.13.4 (diff)
downloadgentoo-a93e8152ea03abae6a8040546390ac803da75435.tar.gz
gentoo-a93e8152ea03abae6a8040546390ac803da75435.tar.bz2
gentoo-a93e8152ea03abae6a8040546390ac803da75435.zip
app-admin/ansible: add 6.3.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-6.3.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-6.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-6.3.0.ebuild b/app-admin/ansible/ansible-6.3.0.ebuild
new file mode 100644
index 000000000000..cf0da827da5f
--- /dev/null
+++ b/app-admin/ansible/ansible-6.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.13.0
+ <app-admin/ansible-core-2.14"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}