summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2016-02-19 17:55:08 +0100
committerDaniel Pielmeier <billie@gentoo.org>2016-02-19 17:55:08 +0100
commitba6473341f414f64c355302901890f5b3d9d752d (patch)
tree94b9de339e703918789f67c599a517d05771a1f8 /app-admin/conky
parentwww-servers/adsf: fix metadata per GLEP 67 (diff)
downloadgentoo-ba6473341f414f64c355302901890f5b3d9d752d.tar.gz
gentoo-ba6473341f414f64c355302901890f5b3d9d752d.tar.bz2
gentoo-ba6473341f414f64c355302901890f5b3d9d752d.zip
app-admin/conky: Add patch to build with wifi support.
This fixes bug #573502. Thanks to Stanislav Nikitin for the report and Till Schäfer for testing the patch. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/conky-1.10.1.ebuild2
-rw-r--r--app-admin/conky/files/conky-1.10.1-includewlan.patch13
2 files changed, 15 insertions, 0 deletions
diff --git a/app-admin/conky/conky-1.10.1.ebuild b/app-admin/conky/conky-1.10.1.ebuild
index 86a87b87e642..be3ce3f1f88e 100644
--- a/app-admin/conky/conky-1.10.1.ebuild
+++ b/app-admin/conky/conky-1.10.1.ebuild
@@ -76,6 +76,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${P}-includewlan.patch"
+
# Allow user patches #478482
epatch_user
}
diff --git a/app-admin/conky/files/conky-1.10.1-includewlan.patch b/app-admin/conky/files/conky-1.10.1-includewlan.patch
new file mode 100644
index 000000000000..82b09a749b9a
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.1-includewlan.patch
@@ -0,0 +1,13 @@
+diff -Naur a/cmake/ConkyPlatformChecks.cmake b/cmake/ConkyPlatformChecks.cmake
+--- a/cmake/ConkyPlatformChecks.cmake 2015-11-18 20:47:45.000000000 +0500
++++ b/cmake/ConkyPlatformChecks.cmake 2016-01-31 20:04:58.036144590 +0500
+@@ -141,7 +141,8 @@
+ endif(BUILD_MYSQL)
+
+ if(BUILD_WLAN)
+- check_include_file(iwlib.h IWLIB_H -D_GNU_SOURCE)
++ set(CMAKE_REQUIRED_DEFINITIONS -D_GNU_SOURCE)
++ check_include_files(iwlib.h IWLIB_H -D_GNU_SOURCE)
+ if(NOT IWLIB_H)
+ message(FATAL_ERROR "Unable to find iwlib.h")
+ endif(NOT IWLIB_H)