summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-10-17 18:56:55 -0700
committerZac Medico <zmedico@gentoo.org>2022-10-17 18:57:03 -0700
commit1eab4a3b1f496d4c16f214eb436e706f3774e9c7 (patch)
tree315e4b133ed71993534e2dbf3167951b62e2beda /app-admin/consul-template
parentsys-cluster/minikube: add 1.27.1 (diff)
downloadgentoo-1eab4a3b1f496d4c16f214eb436e706f3774e9c7.tar.gz
gentoo-1eab4a3b1f496d4c16f214eb436e706f3774e9c7.tar.bz2
gentoo-1eab4a3b1f496d4c16f214eb436e706f3774e9c7.zip
app-admin/consul-template: add 0.29.5
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-admin/consul-template')
-rw-r--r--app-admin/consul-template/Manifest1
-rw-r--r--app-admin/consul-template/consul-template-0.29.5.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/consul-template/Manifest b/app-admin/consul-template/Manifest
index b5f4e0463115..9f9605c32056 100644
--- a/app-admin/consul-template/Manifest
+++ b/app-admin/consul-template/Manifest
@@ -4,3 +4,4 @@ DIST consul-template-0.29.1-deps.tar.xz 59041120 BLAKE2B dd822c41cf9fdfe773ed48e
DIST consul-template-0.29.1.tar.gz 254592 BLAKE2B 4ad5e7c1bf2edc06d72ec1ed48f9546c698d22f8562c4c9924106891c44511b912abecc94517ed2359592b709f1f8fd05fcb00cea52893de29c62b34b61fd71e SHA512 edcfe45a3d98b9affda8b5d07fb375a647a78473c7041a87f1f5a2aa2faef2bfdef26a7037d228f6a86d0c446397e7452e7005ce16beff2bc68edabf2268a6f9
DIST consul-template-0.29.4-deps.tar.xz 59446648 BLAKE2B 9ccd689f38eff50ad448a4226de918920c7acca9eb1e23d4e30f9999afc124224bb8f123b3dff4a1d433ea683ed523cd604a41472f50cb1919483040fc18c848 SHA512 3c60d88fdb82744f250cf02be3b3423f74360f18a43f4c4204ee97f73c370b878ecdbd5a300f96b74ffd9c7cde66f6c8b974392f7acc07a113b85ab6f1b6d8e9
DIST consul-template-0.29.4.tar.gz 262539 BLAKE2B 487902c2a05561db325e6d2638a70d2733a27dd31f678b65883d0b4925b4efa38fe4fbe6c7128c9473af4d4a21f467288a2c1945da399f6feab39216b67dd5aa SHA512 3bc5fcd1877fe125398d6bf0bd4938af88cacf726441af3e82142e651ab458185593eec3cb7c5916669a0e39dff8059c049556509ec279bf572f03b4c915d757
+DIST consul-template-0.29.5.tar.gz 262722 BLAKE2B 1e3ddf259d76cf487872cebbe8c8b5bb313b89d073b26496340d39cc55c4e56ec531cbefec4bc1c0dd5c8bb3bd707c9bebfd15011e421badf12ea59a5bbbdbe3 SHA512 f753c2ec7f6c97ac73b34820b40568b5b16a3b8d4bebc7390905614a96744e8d4afd4a63b8b911989ba084ea91d85a21e3283d67a36bf65a685aa63154361a14
diff --git a/app-admin/consul-template/consul-template-0.29.5.ebuild b/app-admin/consul-template/consul-template-0.29.5.ebuild
new file mode 100644
index 000000000000..6727d40a8f93
--- /dev/null
+++ b/app-admin/consul-template/consul-template-0.29.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module systemd
+
+DESCRIPTION="Generic template rendering and notifications with Consul"
+HOMEPAGE="https://github.com/hashicorp/consul-template"
+SRC_URI="https://github.com/hashicorp/consul-template/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/consul-template-0.29.4-deps.tar.xz"
+
+LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 ISC MIT WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ acct-group/consul-template
+ acct-user/consul-template"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+# TODO: debug test failures
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ # remove -s and -w from the linker flags
+ sed \
+ -e '/-s \\/d' \
+ -e '/-w \\/d' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake GOBIN="${S}"/bin dev
+}
+
+src_test() {
+ emake GOBIN="${S}"/bin test
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc CHANGELOG.md README.md
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ keepdir /etc/${PN}.d
+
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}