summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/fam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/fam')
-rw-r--r--app-admin/fam/Manifest2
-rw-r--r--app-admin/fam/fam-2.7.0-r6.ebuild47
-rw-r--r--app-admin/fam/fam-2.7.0-r7.ebuild53
-rw-r--r--app-admin/fam/files/famd27
-rw-r--r--app-admin/fam/metadata.xml8
5 files changed, 137 insertions, 0 deletions
diff --git a/app-admin/fam/Manifest b/app-admin/fam/Manifest
new file mode 100644
index 000000000000..1fd9fb726985
--- /dev/null
+++ b/app-admin/fam/Manifest
@@ -0,0 +1,2 @@
+DIST fam-2.7.0.tar.gz 301974 SHA256 1e0aa136693a3e9f4b43ebd71e7bd934cea31817a4a6cba2edc7aac353b8a93f SHA512 62b6222ee925eb2af1e258097c9bb676191690f38f8504ae16b1883a1019e0ac6dc7116ac2c4c596a956b3b3cfc3ce3ee7b613c319654681afb13e3ad3f284e2 WHIRLPOOL de90043aaaa6fd792975c13589564f85feb735738b9476b57e80d26a224fcb6f3a858ae383417e5ea48c2fa28b1a7e9c33d729caff5bb417bfbfa840ec228e47
+DIST fam_2.7.0-17.diff.gz 28056 SHA256 2362384d1fbde5dcbccf70f617aedbcae44d3f826a5b9df1331b070da1e0d5c2 SHA512 76b14e1d17713eb86d52cb804d34012e5369b5f4e8bcbdc73a063d2ad9219e0c4a261cef9e144ee07744a953a2e893bdf2ceeefcf21edc7a2ac5e70a51a8e209 WHIRLPOOL 59ed522ccfc8825051d1b281ced215c8b045dc0021bf0f28755aeb1f580ebb6eddb09934128aed51e91ea3d0ac24bfd976f0733ac90b7ef0e377fa982996efbd
diff --git a/app-admin/fam/fam-2.7.0-r6.ebuild b/app-admin/fam/fam-2.7.0-r6.ebuild
new file mode 100644
index 000000000000..1ffd072cb2df
--- /dev/null
+++ b/app-admin/fam/fam-2.7.0-r6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DEBIAN_PATCH="17"
+DESCRIPTION="FAM, the File Alteration Monitor"
+HOMEPAGE="http://oss.sgi.com/projects/fam/"
+SRC_URI="ftp://oss.sgi.com/projects/fam/download/stable/${P}.tar.gz
+ mirror://debian/pool/main/f/${PN}/${P/-/_}-${DEBIAN_PATCH}.diff.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static-libs"
+
+DEPEND="|| ( net-nds/rpcbind >=net-nds/portmap-5b-r6 )
+ !app-admin/gamin"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS TODO README )
+
+src_prepare() {
+ epatch "${WORKDIR}/${P/-/_}-${DEBIAN_PATCH}.diff"
+ edos2unix "${S}"/${P}/debian/patches/10_debianbug375967.patch
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch "${S}"/${P}/debian/patches
+ sed -i configure.ac -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ sed -i "${D}"/etc/fam.conf \
+ -e "s:local_only = false:local_only = true:g" \
+ || die "sed fam.conf"
+
+ doinitd "${FILESDIR}/famd"
+}
diff --git a/app-admin/fam/fam-2.7.0-r7.ebuild b/app-admin/fam/fam-2.7.0-r7.ebuild
new file mode 100644
index 000000000000..0855b9eb0724
--- /dev/null
+++ b/app-admin/fam/fam-2.7.0-r7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools multilib-minimal
+
+DEBIAN_PATCH="17"
+DESCRIPTION="FAM, the File Alteration Monitor"
+HOMEPAGE="http://oss.sgi.com/projects/fam/"
+SRC_URI="ftp://oss.sgi.com/projects/fam/download/stable/${P}.tar.gz
+ mirror://debian/pool/main/f/${PN}/${P/-/_}-${DEBIAN_PATCH}.diff.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="static-libs"
+
+DEPEND="|| ( net-nds/rpcbind >=net-nds/portmap-5b-r6 )
+ !app-admin/gamin"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS TODO README )
+
+src_prepare() {
+ epatch "${WORKDIR}/${P/-/_}-${DEBIAN_PATCH}.diff"
+ edos2unix "${S}"/${P}/debian/patches/10_debianbug375967.patch
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch "${S}"/${P}/debian/patches
+ sed -i configure.ac -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf $(use_enable static-libs static)
+
+ # These are thrown away later
+ if ! multilib_is_native_abi ; then
+ sed -i -e 's/src conf man//' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+
+ sed -i "${D}"/etc/fam.conf \
+ -e "s:local_only = false:local_only = true:g" \
+ || die "sed fam.conf"
+
+ doinitd "${FILESDIR}/famd"
+}
diff --git a/app-admin/fam/files/famd b/app-admin/fam/files/famd
new file mode 100644
index 000000000000..e32f0a364ad6
--- /dev/null
+++ b/app-admin/fam/files/famd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+
+ need portmap
+
+}
+
+start() {
+
+ ebegin "Starting famd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/famd \
+ -- -T 0 -c /etc/fam.conf
+ eend $?
+
+}
+
+stop() {
+
+ ebegin "Stopping famd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/famd
+ eend $?
+
+}
diff --git a/app-admin/fam/metadata.xml b/app-admin/fam/metadata.xml
new file mode 100644
index 000000000000..52363bff0cba
--- /dev/null
+++ b/app-admin/fam/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+ </maintainer>
+</pkgmetadata>