summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-03-12 22:23:50 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-03-12 22:24:16 -0700
commit0dd86ed01ecd13b32a282d228937be391ceebb6b (patch)
tree2fb2eaaad612d75387a677f7cfb72561f8ba9c51 /app-admin/fifo-cronolog
parentsci-mathematics/wxmaxima: remove old versions (diff)
downloadgentoo-0dd86ed01ecd13b32a282d228937be391ceebb6b.tar.gz
gentoo-0dd86ed01ecd13b32a282d228937be391ceebb6b.tar.bz2
gentoo-0dd86ed01ecd13b32a282d228937be391ceebb6b.zip
app-admin/fifo-cronolog: bump, systemd support
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-admin/fifo-cronolog')
-rw-r--r--app-admin/fifo-cronolog/Manifest1
-rw-r--r--app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/fifo-cronolog/Manifest b/app-admin/fifo-cronolog/Manifest
index ba3b49b49b23..a35f7f1febc4 100644
--- a/app-admin/fifo-cronolog/Manifest
+++ b/app-admin/fifo-cronolog/Manifest
@@ -1 +1,2 @@
DIST fifo-cronolog-1.1.1.tar.bz2 3124 BLAKE2B 6e9cb35e0ed1b54c3baed4451742840dc1144294fc675822c1260d4d7d885a52f8835e60dcbed57c714e40e94e6d51b3ba78af9b9892883f5f520a7c57d30df8 SHA512 3ac809d5cfc951764aaf31d50ee394b0dde9ced16f53daa91c81bdb218af2bab410ff945ebfdeb8307a55bda3292c0a55eb500c3cb73595e17228ef739455d90
+DIST fifo-cronolog-1.2.3.tar.gz 4518 BLAKE2B c227304d98b2467a1ed7352399b1e53aba4dc005fa30a1be73b8cc96d61ee49d5f6a3703ccddd1ffef652c4090e9b5dfed9cce3f1254b959a1ccc07aac78b3f6 SHA512 557be1a663c5754a293092078b8a3710474bb1939c1ee65e4c560056238ca646e941e4ad82c0a90c02834fc90ddb2aae9047a4e73d42cf8c2c013f2a5d2c839c
diff --git a/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild b/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild
new file mode 100644
index 000000000000..940b4376a493
--- /dev/null
+++ b/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="cronolog wrapper for use with dumb daemons like squid, varnish and so on"
+HOMEPAGE="https://gitweb.gentoo.org/proj/fifo-cronolog.git"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/cronolog"
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ dosbin fifo-cronolog
+ dosym fifo-cronolog /usr/sbin/squid-cronolog
+ dosbin fifo-cronolog-setup
+
+ newinitd openrc/fifo-cronolog.initd fifo-cronolog
+ newconfd openrc/fifo-cronolog.confd fifo-cronolog
+
+ systemd_douserunit systemd/fifo-cronolog@.service
+ dodoc README.md systemd/fifo-cronolog@example.service.env
+}
+
+pkg_postinst() {
+ elog "Warning: app-admin/squid-cronolog has been renamed to app-admin/fifo-cronolog."
+ elog "This also applies to the binary 'squid-cronolog' but there is a symlink for now"
+ elog "Please fix your scripts/configs."
+}