summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-12-11 15:06:40 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-12-11 15:07:00 +0100
commit40f4c38ff1f938261bac47902b28b6f465aa44b7 (patch)
tree947048ae00b4a2fdeec3b06de57ec95ad5dcf2be /app-admin/keepassx/keepassx-0.4.4.ebuild
parentsys-fs/ctmg: fix manifest (diff)
downloadgentoo-40f4c38ff1f938261bac47902b28b6f465aa44b7.tar.gz
gentoo-40f4c38ff1f938261bac47902b28b6f465aa44b7.tar.bz2
gentoo-40f4c38ff1f938261bac47902b28b6f465aa44b7.zip
app-admin/keepassx: Security bump to version 0.4.4
https://www.keepassx.org/news/2015/12/551 Fixes CVE-2015-8359 and CVE-2015-8378 Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-admin/keepassx/keepassx-0.4.4.ebuild')
-rw-r--r--app-admin/keepassx/keepassx-0.4.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/keepassx/keepassx-0.4.4.ebuild b/app-admin/keepassx/keepassx-0.4.4.ebuild
new file mode 100644
index 000000000000..d838ba4b9ea1
--- /dev/null
+++ b/app-admin/keepassx/keepassx-0.4.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qt4-r2
+
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
+HOMEPAGE="http://www.keepassx.org/"
+SRC_URI="https://www.keepassx.org/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pch"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtxmlpatterns:4
+ >=x11-libs/libXtst-1.1.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.3-gcc47.patch )
+
+src_configure() {
+ local conf_pch
+ use pch && conf_pch="PRECOMPILED=1" || conf_pch="PRECOMPILED=0"
+
+ eqmake4 ${PN}.pro -recursive \
+ PREFIX="${ED}/usr" \
+ "${conf_pch}"
+}
+
+src_compile() {
+ # workaround compile failure due to distcc, bug #214327
+ PATH=${PATH/\/usr\/lib\/distcc\/bin:}
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc changelog
+}