summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/multilog-watch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/multilog-watch')
-rw-r--r--app-admin/multilog-watch/Manifest2
-rw-r--r--app-admin/multilog-watch/metadata.xml13
-rw-r--r--app-admin/multilog-watch/multilog-watch-1.12.ebuild39
3 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/multilog-watch/Manifest b/app-admin/multilog-watch/Manifest
new file mode 100644
index 000000000000..30795fd44bd0
--- /dev/null
+++ b/app-admin/multilog-watch/Manifest
@@ -0,0 +1,2 @@
+DIST multilog-watch 12291 SHA256 595b5783eeefc1b9bae0b674f5ad5c7e6c926b97733b072450d36b4f36a71c98 SHA512 e28933b005243261a9f92c2a3a19e15ac4da2c3a505422e3521f2f1888a6cf5cdac2ee1161449334d27f4a7669b1f266d6760f12641ecf066629e26c98fcd041 WHIRLPOOL c0cd6c1f233d75a14c4ea3ab97d50e0d7dc5924e838b7d5046ef41ce9036dd43462e73d4876e4de56eb3beeabb5ca366a6cc0e6b4ac9bb11032ebcdac240af6d
+DIST sample.filter 1041 SHA256 98a0a948c21dd19292117819dd0ac6ba0150e78210f3dbbabd6eb3a6e574a8ef SHA512 5164461010629f22c9c19d3341251d3723f5dbc02719e19f7f94c5c4154c0e246b365d9d555f88c9589c95b0fbeabb1408137d4782b1c360325460a008192ed5 WHIRLPOOL 89004a184a10599242b8f82352209a5a1df8db7bb89d0aec82f8b4014e4548f2200e3934713444f1dc1b1be0adb3bc455f326afed1920643295795cb406d5b86
diff --git a/app-admin/multilog-watch/metadata.xml b/app-admin/multilog-watch/metadata.xml
new file mode 100644
index 000000000000..474ccaa45709
--- /dev/null
+++ b/app-admin/multilog-watch/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">This program reads logs written by multilog (part of the
+daemontools package by Dan Bernstein), discards any lines matching regular
+expressions in its configuration file, and mails the rest to a configured e-mail
+address. The e-mail is sent using qmail-remote directly, which requires qmail be
+installed on the system but which allows multilog-watch to send mail even if the
+local mail system is down.</longdescription>
+</pkgmetadata>
diff --git a/app-admin/multilog-watch/multilog-watch-1.12.ebuild b/app-admin/multilog-watch/multilog-watch-1.12.ebuild
new file mode 100644
index 000000000000..bad3fb80fed8
--- /dev/null
+++ b/app-admin/multilog-watch/multilog-watch-1.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+DESCRIPTION="Watches a multilog file for irregularities"
+
+HOMEPAGE="http://www.eyrie.org/~eagle/software/multilog-watch/"
+SRC_URI="http://archives.eyrie.org/software/system/multilog-watch
+http://www.eyrie.org/%7Eeagle/software/multilog-watch/sample.filter"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ virtual/qmail"
+
+src_unpack() {
+ mkdir "${S}"
+ cp "${DISTDIR}"/multilog-watch "${S}"
+ cp "${DISTDIR}"/sample.filter "${S}"
+}
+
+src_compile() {
+ mv multilog-watch multilog-watch.orig
+ sed -e 's/\/etc\/leland/\/etc\/multilog-watch/' multilog-watch.orig > multilog-watch
+ /usr/bin/pod2man -s 1 multilog-watch multilog-watch.1
+}
+
+src_install() {
+ dodir /etc/multilog-watch
+ insinto /etc/multilog-watch
+ doins sample.filter
+
+ dobin multilog-watch || die 'install failed'
+ doman multilog-watch.1
+}