summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-15 19:00:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-15 19:16:50 +0100
commit8fcceac282a29098fb8504f2f000b38efb08ec44 (patch)
tree355ca350e5898de5934af6aa4098317bed215c2f /app-admin/salt
parentapp-admin/pwman3: Remove py3.8-only versions (diff)
downloadgentoo-8fcceac282a29098fb8504f2f000b38efb08ec44.tar.gz
gentoo-8fcceac282a29098fb8504f2f000b38efb08ec44.tar.bz2
gentoo-8fcceac282a29098fb8504f2f000b38efb08ec44.zip
app-admin/salt: Clean <=py3.8 leftovers
Remove python_gen_cond_dep from an ancient era of libvirt-python not supporting newer Python implementations, as well as obsolete postinst messages. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/salt')
-rw-r--r--app-admin/salt/salt-3002.9-r1.ebuild17
-rw-r--r--app-admin/salt/salt-3003.5-r2.ebuild17
-rw-r--r--app-admin/salt/salt-3004.2-r2.ebuild17
3 files changed, 6 insertions, 45 deletions
diff --git a/app-admin/salt/salt-3002.9-r1.ebuild b/app-admin/salt/salt-3002.9-r1.ebuild
index 2fa91367775a..e5ddadf4d133 100644
--- a/app-admin/salt/salt-3002.9-r1.ebuild
+++ b/app-admin/salt/salt-3002.9-r1.ebuild
@@ -44,7 +44,7 @@ RDEPEND="
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
<dev-python/importlib_metadata-5[${PYTHON_USEDEP}]
libvirt? (
- $(python_gen_cond_dep 'dev-python/libvirt-python[${PYTHON_USEDEP}]' python3_8)
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
)
openssl? (
dev-libs/openssl:0=[-bindist(-)]
@@ -184,18 +184,5 @@ python_test() {
}
pkg_postinst() {
- if use python_targets_python3_8; then
- if use nova; then
- ewarn "Salt's nova functionality will not work with python3.8 since"
- ewarn "dev-python/python-novaclient does not support it yet"
- fi
- if use neutron; then
- ewarn "Salt's neutron functionality will not work with python3.8 since"
- ewarn "dev-python/python-neutronclient does not support it yet"
- fi
- if use libvirt; then
- ewarn "Salt's libvirt functionality will not work with python3.8 since"
- ewarn "dev-python/libvirt-python does not support it yet"
- fi
- fi
+ :
}
diff --git a/app-admin/salt/salt-3003.5-r2.ebuild b/app-admin/salt/salt-3003.5-r2.ebuild
index 3cd254df3aa9..6c24958787ad 100644
--- a/app-admin/salt/salt-3003.5-r2.ebuild
+++ b/app-admin/salt/salt-3003.5-r2.ebuild
@@ -44,7 +44,7 @@ RDEPEND="
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
<dev-python/importlib_metadata-5[${PYTHON_USEDEP}]
libvirt? (
- $(python_gen_cond_dep 'dev-python/libvirt-python[${PYTHON_USEDEP}]' python3_8)
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
)
openssl? (
dev-libs/openssl:0=[-bindist(-)]
@@ -193,18 +193,5 @@ python_test() {
}
pkg_postinst() {
- if use python_targets_python3_8; then
- if use nova; then
- ewarn "Salt's nova functionality will not work with python3.8 since"
- ewarn "dev-python/python-novaclient does not support it yet"
- fi
- if use neutron; then
- ewarn "Salt's neutron functionality will not work with python3.8 since"
- ewarn "dev-python/python-neutronclient does not support it yet"
- fi
- if use libvirt; then
- ewarn "Salt's libvirt functionality will not work with python3.8 since"
- ewarn "dev-python/libvirt-python does not support it yet"
- fi
- fi
+ :
}
diff --git a/app-admin/salt/salt-3004.2-r2.ebuild b/app-admin/salt/salt-3004.2-r2.ebuild
index 1e3ce475d192..8657b4a8139f 100644
--- a/app-admin/salt/salt-3004.2-r2.ebuild
+++ b/app-admin/salt/salt-3004.2-r2.ebuild
@@ -45,7 +45,7 @@ RDEPEND="
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
<dev-python/importlib_metadata-5[${PYTHON_USEDEP}]
libvirt? (
- $(python_gen_cond_dep 'dev-python/libvirt-python[${PYTHON_USEDEP}]' python3_8)
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
)
openssl? (
dev-libs/openssl:0=[-bindist(-)]
@@ -193,18 +193,5 @@ python_test() {
}
pkg_postinst() {
- if use python_targets_python3_8; then
- if use nova; then
- ewarn "Salt's nova functionality will not work with python3.8 since"
- ewarn "dev-python/python-novaclient does not support it yet"
- fi
- if use neutron; then
- ewarn "Salt's neutron functionality will not work with python3.8 since"
- ewarn "dev-python/python-neutronclient does not support it yet"
- fi
- if use libvirt; then
- ewarn "Salt's libvirt functionality will not work with python3.8 since"
- ewarn "dev-python/libvirt-python does not support it yet"
- fi
- fi
+ :
}