summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-10-25 07:28:14 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-10-25 07:28:14 +0300
commit06356aff0ab803d2091c3780b9743175714b4fab (patch)
tree14516e24fdf30e64add0fd9ddb1f4a370b97f123 /app-admin
parentapp-admin/linode-cli: add 5.53.1 (diff)
downloadgentoo-06356aff0ab803d2091c3780b9743175714b4fab.tar.gz
gentoo-06356aff0ab803d2091c3780b9743175714b4fab.tar.bz2
gentoo-06356aff0ab803d2091c3780b9743175714b4fab.zip
app-admin/linode-cli: drop 5.53.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/linode-cli/Manifest1
-rw-r--r--app-admin/linode-cli/linode-cli-5.53.0.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
index 005ea8cfc61c..17318b2a3cd4 100644
--- a/app-admin/linode-cli/Manifest
+++ b/app-admin/linode-cli/Manifest
@@ -1,3 +1,2 @@
DIST linode_cli-5.52.0.tar.gz 160729 BLAKE2B dc0a4c30dcaab3c07c64aa519786f461a79e6f532ebfcc9917e6654b6a8bd32b2cfa2f323036d3870555b7b91620121264877a0fbae4b1bc2a71e885558bb261 SHA512 26c774e0936e16f391c5b028ffc91370d6401e85e92f08ce2e3b2435be3a8230d0d8edd3904ff0514c76b135a3ff88fae27e5e452d0aae534b0deb6f9fc8a2ff
-DIST linode_cli-5.53.0.tar.gz 154080 BLAKE2B fefb0dee416dda6cdeb2f97120566f5c07e15b44bf1659cd73f6a64782cd30d85fb6012c1ee372bd5b66767d2b8dc9513edc6a5817b140403d15384599b5ec48 SHA512 16510afad1e7f23a3b868fed80ce7d58696da3130d536660353590b2371987f8a8d5e25a66d14fe7787bf383071790c68379a6e0f3a21f9b1b207c117a07d13c
DIST linode_cli-5.53.1.tar.gz 154260 BLAKE2B c2c9d00f0686bcd4d083974c7c2e167963a6af2d04c244c854937e2301de6df62cf82d872aa53f01150bb657895bccedba1df2ce4d6d091ce27c7abd599d2250 SHA512 ea7b8cf42f041deca2e745d4e8113beb2c46a3a79e5a56b57a24379581eca793e2f3e0d0b5821e3644450eb4da207c3884098ad33e9ec62775657a625ed4a849
diff --git a/app-admin/linode-cli/linode-cli-5.53.0.ebuild b/app-admin/linode-cli/linode-cli-5.53.0.ebuild
deleted file mode 100644
index 21d1ca44d811..000000000000
--- a/app-admin/linode-cli/linode-cli-5.53.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi shell-completion
-
-DESCRIPTION="Official command-line interface for interacting with the Linode API"
-HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# Tests require network, a linode account and an API key.
-# WARNING: tests will incur costs and will wipe the account.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/boto3[${PYTHON_USEDEP}]
- >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
- dev-python/openapi3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- <dev-python/urllib3-3[${PYTHON_USEDEP}]
-"
-
-python_install_all() {
- distutils-r1_python_install_all
-
- PYTHONPATH=. ${EPYTHON} linodecli completion bash > "${T}/${PN}".bash || die
- PYTHONPATH=. ${EPYTHON} linodecli completion fish > "${T}/${PN}".fish || die
-
- newbashcomp "${T}/${PN}".bash ${PN}
- newfishcomp "${T}/${PN}".fish ${PN}
-
- dosym ${PN} "$(get_bashcompdir)"/linode
- dosym ${PN} "$(get_bashcompdir)"/lin
- dosym ${PN} "$(get_fishcompdir)"/linode
- dosym ${PN} "$(get_fishcompdir)"/lin
-}