summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-01-17 16:23:57 +0100
committerAgostino Sarubbo <ago@gentoo.org>2024-01-17 16:23:57 +0100
commit1a335bd46f2ea874bc45b8a63c326ee9925bb49a (patch)
tree63ef3cf2d8362218144d3e4fc040c4357599b98d /app-admin
parentapp-admin/kernel-hardening-checker: version bump to 0.6.6 (diff)
downloadgentoo-1a335bd46f2ea874bc45b8a63c326ee9925bb49a.tar.gz
gentoo-1a335bd46f2ea874bc45b8a63c326ee9925bb49a.tar.bz2
gentoo-1a335bd46f2ea874bc45b8a63c326ee9925bb49a.zip
app-admin/hcloud: version bump to 1.41.1
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/hcloud/Manifest1
-rw-r--r--app-admin/hcloud/hcloud-1.41.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/hcloud/Manifest b/app-admin/hcloud/Manifest
index b5228203782a..1aa064e66b92 100644
--- a/app-admin/hcloud/Manifest
+++ b/app-admin/hcloud/Manifest
@@ -1,2 +1,3 @@
DIST hcloud-1.37.0.tar.xz 1868892 BLAKE2B 40268017c28877a5d26cb752e28511de591ca8dac9ab834b8ad5d15005306910a80501659ed1f827ca7184f1399a054519360c3a27d4081d08346bca53978537 SHA512 c785851a2085511bfb9b257a7267f51b4c8bcc9d14f6b595d772712aeb99c1d9db99a481b211bf110ee5c0fd260cc5a98d3dc5445a68807d5abeb050d0e89b81
DIST hcloud-1.41.0.tar.xz 1915204 BLAKE2B f7a28ef8ec991380e893200a6f9dbc01a43adbc88bbf1b546ead55e353254d8024d7f7d18cc40ca1d273b5a1f632f672258657066da0bd4ea9e2f70302c56954 SHA512 1bc0ab6d19db9d244c22b23055bd4f0c06264ddcdd5d8805aae99f3bf53045e1284426bed6229f47f6727b914f7eebc70ae5576d035b5c9e41839b46f1b4b363
+DIST hcloud-1.41.1.tar.xz 1869464 BLAKE2B 4ce755ae14bdfe5e90b673a31f3002ae812449593c3ba4fb08ec3ad0fe21cb2d57bf1dbe0f744d39b4844b165e49a86663a20bad1389d1468e052dbb6163deed SHA512 0e2236d0c4efabccca090866a87d7938d2eb39885b7901e3874c40e1ce672515376edc69471b411e862b1269ac538db380347738362bed1464064c4f6799f933
diff --git a/app-admin/hcloud/hcloud-1.41.1.ebuild b/app-admin/hcloud/hcloud-1.41.1.ebuild
new file mode 100644
index 000000000000..8b7fa66f4318
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.41.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND=">=dev-lang/go-1.18:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
+}
+
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}