summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-02-04 10:35:50 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-02-04 10:35:50 -0600
commitb3329669d5800c14221011fcd69dd5d9b37a26eb (patch)
treeabc25aee5f38b48081e5cab6305e27d82f9b0343 /app-admin
parentmedia-fonts/iosevka: add 28.1.0 (diff)
downloadgentoo-b3329669d5800c14221011fcd69dd5d9b37a26eb.tar.gz
gentoo-b3329669d5800c14221011fcd69dd5d9b37a26eb.tar.bz2
gentoo-b3329669d5800c14221011fcd69dd5d9b37a26eb.zip
app-admin/ansible-core: drop 2.14.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-core/Manifest1
-rw-r--r--app-admin/ansible-core/ansible-core-2.14.12.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/app-admin/ansible-core/Manifest b/app-admin/ansible-core/Manifest
index 92ef082a0955..77e82f2c47f9 100644
--- a/app-admin/ansible-core/Manifest
+++ b/app-admin/ansible-core/Manifest
@@ -1,4 +1,3 @@
-DIST ansible-core-2.14.12.tar.gz 3144432 BLAKE2B 7c7e1f73a19e6033b7b230ac6505d34aeb57b75bfe0ece88332b98aa1cd0c6a27eb843829cbe25b5956dd602143171a6eea313cdd97f53b0ddeceefe905955e5 SHA512 648835f2b025ca37c1b88a47eb34ce972c15e66563e14573b9ad9e518cf0d96af882784495311724a5d66cb028fc65aa351e56f827d328032a95c9fb0c882bd8
DIST ansible-core-2.14.13.tar.gz 3145413 BLAKE2B 75b11feaaefa9a63c6f83f64c796ceacf7c6b08322ac0b85f6dcf968db7b80cc97262ea6f8f839e5e41e800ad7cae610e96f312c1ae0f58882c8891246a81b8a SHA512 195885815d40448d8497eae9533a4104c4b9f17ab3a812d544a403f41d2e77e7be2c15bae5a6df07563499052beb273580a569d51b667d0a9c5a16e55b35258a
DIST ansible-core-2.15.7.tar.gz 3159286 BLAKE2B 8efcc68dc01beaf9dfd7b7988dcc8c9581e390813a0b04514c69d674cbf6fef19e8b46950a03b558cd7de0c394d6923ddae85aa8a4f32f60b7abb63f73ad2a3c SHA512 f94416122040c945dc871fa0f897e3bc3d02e43459573bc5e7fa4f1988b1d7b5be306cb48e9ebc59dd111e710c462a5e421312f909f8476d6ae5d3bc6b493c4d
DIST ansible-core-2.15.8.tar.gz 3160606 BLAKE2B 439a3f584940e5ab46b43b0b47395e0618a3ea52c67ebcd51667f31220cb038dda35506e7843d177d555b77a55a9d2c6245a916741ab1dcdf222c535afb5f83d SHA512 020191ef4b005abbf799204da68270bd4f13a85c7f23cb9dffe85b1c5c093c0ad86e061211ab9fcc8fd0be9367717fb0baadefb1ebecd3579471120fb2e8647f
diff --git a/app-admin/ansible-core/ansible-core-2.14.12.ebuild b/app-admin/ansible-core/ansible-core-2.14.12.ebuild
deleted file mode 100644
index 756b42643396..000000000000
--- a/app-admin/ansible-core/ansible-core-2.14.12.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-PYPI_NO_NORMALIZE=1
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://www.ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- inherit pypi
- KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/resolvelib.patch"
-)
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
- <dev-python/resolvelib-1.1.0[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-BDEPEND="
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- dev-python/botocore[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}