summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-28 11:11:01 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-28 11:11:01 +0200
commitcf6fb2cbf01ace6e0fce246abbb284e65d6ec814 (patch)
treef5916f050c060645574066cdbfb8f9f4169ddab1 /app-arch/qpress/qpress-1.1.ebuild
parentapp-arch/mt-st: [QA] Fix ${HOMEPAGE} in SRC_URI (diff)
downloadgentoo-cf6fb2cbf01ace6e0fce246abbb284e65d6ec814.tar.gz
gentoo-cf6fb2cbf01ace6e0fce246abbb284e65d6ec814.tar.bz2
gentoo-cf6fb2cbf01ace6e0fce246abbb284e65d6ec814.zip
app-arch/qpress: Port to EAPI 7
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch/qpress/qpress-1.1.ebuild')
-rw-r--r--app-arch/qpress/qpress-1.1.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-arch/qpress/qpress-1.1.ebuild b/app-arch/qpress/qpress-1.1.ebuild
index e7787c7973a5..21904daf9eb3 100644
--- a/app-arch/qpress/qpress-1.1.ebuild
+++ b/app-arch/qpress/qpress-1.1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="A portable file archiver using QuickLZ algorithm"
HOMEPAGE="http://www.quicklz.com/"
@@ -11,14 +13,18 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+BDEPEND="app-arch/unzip"
+
S="${WORKDIR}"
-src_prepare() {
- default
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-fix-includes.patch
+ "${FILESDIR}"/${PN}-1.1-fix-build-system.patch
+)
- # Fix compilation with newer gcc
- sed -i '1i #include <unistd.h>' qpress.cpp || die
- cp "${FILESDIR}/makefile" "${S}" || die
+src_configure() {
+ tc-export CC CXX
+ export LDLIBS="-lpthread"
}
src_install() {