summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-10-12 14:10:58 -0400
committerCraig Andrews <candrews@gentoo.org>2017-10-12 14:21:53 -0400
commit253b163f27eb4b087b79316b5c66f0f9236a5498 (patch)
tree27baab76c47073ad225a27d37b7c749773253ea3 /app-backup/btrbk/btrbk-0.26.0.ebuild
parentapp-backup/btrbk: <=0.25.1 does not work with >=btrfs-progs-4.13.2 (diff)
downloadgentoo-253b163f27eb4b087b79316b5c66f0f9236a5498.tar.gz
gentoo-253b163f27eb4b087b79316b5c66f0f9236a5498.tar.bz2
gentoo-253b163f27eb4b087b79316b5c66f0f9236a5498.zip
app-backup/btrbk: Bump to 0.26.0
Closes: https://github.com/gentoo/gentoo/pull/5929 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'app-backup/btrbk/btrbk-0.26.0.ebuild')
-rw-r--r--app-backup/btrbk/btrbk-0.26.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-backup/btrbk/btrbk-0.26.0.ebuild b/app-backup/btrbk/btrbk-0.26.0.ebuild
new file mode 100644
index 000000000000..8588eb6d0e34
--- /dev/null
+++ b/app-backup/btrbk/btrbk-0.26.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+pv"
+
+DEPEND=">=app-text/asciidoc-8.6.0
+ app-text/xmlto"
+
+RDEPEND="dev-lang/perl
+ net-misc/openssh
+ pv? ( sys-apps/pv )
+ >=sys-fs/btrfs-progs-3.18.2"
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+}
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
+ upgrade_0_26_0_warning="1"
+ fi
+}
+pkg_postinst() {
+ if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
+ ewarn "If you are using raw targets, make sure to run the"
+ ewarn "\"raw_suffix2sidecar\" utility in each target directory."
+ fi
+}