summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-08-06 11:50:55 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-08-06 14:21:52 +0200
commit1a139d2856103a05dd10534c9899e970a2bcafd2 (patch)
treed415eb4d2da457c814fb57027b358b8b40b5d909 /app-backup
parentdev-util/perf: drop 6.8, 6.9 (diff)
downloadgentoo-1a139d2856103a05dd10534c9899e970a2bcafd2.tar.gz
gentoo-1a139d2856103a05dd10534c9899e970a2bcafd2.tar.bz2
gentoo-1a139d2856103a05dd10534c9899e970a2bcafd2.zip
app-backup/borgmatic: add 1.8.13
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.8.13.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 962779ed288c..b5656a7f2259 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,4 +1,5 @@
DIST borgmatic-1.8.10.tar.gz 599453 BLAKE2B 1ae994d452d29139d23940500d7c9f01e7fc1ddbd36254bf0c36d7f56064ccba7fb8434741dd0114d42271eb241098a12f8a07b83046447ae2225f7cd2ab12ae SHA512 10f5d962f6d25ef42ba4d076e238e1986dcfcd9832b3eea08560f367524824fdb0f80f42962ea6a471d711c6a0e293669b85abdc160475c20eed851ce7ad7f42
DIST borgmatic-1.8.11.tar.gz 600265 BLAKE2B 04c5e419de892e636e644185681c3e9ce0ca2dd9b62a043dfdabd38a32ca2f101f6a845fd1ebc68a025625066ea9c53aff9ab1e831a2aeaa566bccb7ec4827c7 SHA512 da19a341713302378409c0e90395a0e5ac4759b1ef593fe53a50113a0c90f130af060d38f49dae80018b8d8605da87415b841fedfc2d2778eee4a690aa5cc311
DIST borgmatic-1.8.12.tar.gz 602369 BLAKE2B 79589e1510be9065d70b48ac5b8ce83a8d82776040cfe0ec833e7c9cbc33e4d285a2292870e2237902900ebb03204c6aafd702a2729b8860aec234429ec00921 SHA512 9cb91a4e7047da4effff69dfaea2358bd0d0897197d306775a3e9e260a2da6cc183c7675e02885fcd3d853c185171372371638b482b3e8b2f1bfcbcb2a14e4b7
+DIST borgmatic-1.8.13.tar.gz 621942 BLAKE2B abea4779d6b8dc2e7885c4e5ff4e6e4a472ecdba8b248f28b137ab25df5c12ce31e71489485966a0df27c8ff388476049ed8f58fcd53d16d09f01e9fa215ac0e SHA512 0057ba195c493c47ecb4eaaca1987b68c332632ebe5015ac20cd5f59f3f8f8b00a06749d828f003866986b3f70c3794a945577f4f49bf775153aa0f75fdfcf49
DIST borgmatic-1.8.9.tar.gz 592715 BLAKE2B 3586404985b8cc0d5575f570ba6679c406e95b83453a7c2414872049067b1736010b9f8498fa92e91d281b1cdf75882bc09e40d6d9e443bff33c399ee1392ff9 SHA512 05386f6321d78e304030ebb78c495aee53a1b6f17241f101e73a097aa4208ac641d6105b1e8161cf714b2eab7c34fe682e082e9e997dc4ac6a6a4207253e8421
diff --git a/app-backup/borgmatic/borgmatic-1.8.13.ebuild b/app-backup/borgmatic/borgmatic-1.8.13.ebuild
new file mode 100644
index 000000000000..de16568a999b
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.8.13.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.13-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.8.0; then
+ ewarn "Please be warned that ${PN}-1.8.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.8.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+}