summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-08 16:43:21 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-08 16:52:03 -0600
commit3bde9b089815b000320a424f12c056080c545e79 (patch)
treebc2ab8abffc4f19ff68e8b3656ebffdd17c05dc6 /app-crypt/acme
parentapp-crypt/acme: 0.20.0 bup (diff)
downloadgentoo-3bde9b089815b000320a424f12c056080c545e79.tar.gz
gentoo-3bde9b089815b000320a424f12c056080c545e79.tar.bz2
gentoo-3bde9b089815b000320a424f12c056080c545e79.zip
app-crypt/acme: update 9999
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/acme-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index a8fc5d0ba458..b02dbde82a94 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -23,15 +23,23 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE="test"
-RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/requests-2.10[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
- >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
python_test() {
nosetests -w ${PN} || die