summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-07-11 21:58:48 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-07-11 22:00:01 -0500
commit74b0138b34e52924a37e5c2c22279a07eff34533 (patch)
tree837d1d3bead1dd53f3f342f683a0fd9a9e534bb0 /app-crypt/certbot-apache
parentapp-crypt/certbot: 1.17.0 bump (diff)
downloadgentoo-74b0138b34e52924a37e5c2c22279a07eff34533.tar.gz
gentoo-74b0138b34e52924a37e5c2c22279a07eff34533.tar.bz2
gentoo-74b0138b34e52924a37e5c2c22279a07eff34533.zip
app-crypt/certbot-apache: 1.17.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.17.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index c931e0f70fe1..75ec98d13ed0 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1 +1,2 @@
DIST certbot-1.16.0.tar.gz 1384177 BLAKE2B 4e46e7d7b9db2f6ef19fab60c2d904f84b502d2911ed496967bbe272db5352c1e9bdb65b8f45358f222214bce4721ceecc12c018b875148bc897f83c5eb63933 SHA512 c2a0c4ea52ab241e387d686a9e5ed67aa5e8b4b7d34ad8996e34562e036c25ab8b397bf482a856758ca787b97bbd78c890189250c0c3d948f03fbf91aa25ece0
+DIST certbot-1.17.0.tar.gz 1386471 BLAKE2B 26cf23c481cc67e1fa0f698dee83dd42b1d382814f10bdb4d2a459f1274f3d661d2a58815c30110701d46362c3fbaee9f57089a7eda1221c9b9dadb2c48dc79d SHA512 104deb8e6e804a3a3f50c730f00307aa39d9d42756f24be009fedc27c889c1575b456455ee11441e341025db6f528359e927a347554ebd57b64c39e789576eda
diff --git a/app-crypt/certbot-apache/certbot-apache-1.17.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.17.0.ebuild
new file mode 100644
index 000000000000..7f0e325d33df
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.17.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"