summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2015-08-16 20:08:07 +0200
committerSven Vermeulen <swift@gentoo.org>2015-08-16 20:16:03 +0200
commit4a2f76fd85afb8c3b4fbdf67153378894bc2b821 (patch)
tree8e2faa6aca16357cc68042e22d75cfb6b56c828e /app-crypt/eid-mw/eid-mw-9999.ebuild
parentmedia-gfx/enblend: Fix texinfo compilation (bug #479978) (diff)
downloadgentoo-4a2f76fd85afb8c3b4fbdf67153378894bc2b821.tar.gz
gentoo-4a2f76fd85afb8c3b4fbdf67153378894bc2b821.tar.bz2
gentoo-4a2f76fd85afb8c3b4fbdf67153378894bc2b821.zip
app-crypt/eid-mw: Update -9999 to drop gtk requirement in newest builds
Provided by Vincent Hardy, this patches the live ebuild to drop the gtk requirement from the code. It also includes the pkgconfig file. Gentoo-Bug: 557604 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-crypt/eid-mw/eid-mw-9999.ebuild')
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild43
1 files changed, 30 insertions, 13 deletions
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
index 9ef575a906b3..06e154cbea82 100644
--- a/app-crypt/eid-mw/eid-mw-9999.ebuild
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -4,18 +4,18 @@
EAPI=5
-inherit eutils versionator mozextension multilib
+inherit eutils autotools mozextension multilib
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
https://github.com/Fedict/${PN}.git"
- inherit git-2 autotools
+ inherit git-2
SRC_URI=""
else
- MY_P="${PN}-${PV/_p/-}"
- SRC_URI="http://eid.belgium.be/en/binaries/${MY_P}.tar_tcm406-258906.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~x86 ~amd64"
- S="${WORKDIR}/eid-mw-$(get_version_component_range 1-3)"
+ MY_P="${P}-v${PV}"
+ SRC_URI="http://eid.belgium.be/en/binaries/${MY_P}.tar_tcm406-270730.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~x86 ~amd64 ~arm"
+ S="${WORKDIR}/${MY_P}"
fi
SLOT="0"
@@ -24,9 +24,12 @@ DESCRIPTION="Belgian Electronic Identity Card middleware supplied by the Belgian
HOMEPAGE="http://eid.belgium.be"
-IUSE="+gtk +xpi"
+IUSE="+gtk +xpi +dialogs"
-RDEPEND="gtk? ( x11-libs/gtk+:2 )
+REQUIRED_USE="
+ dialogs? ( gtk )"
+
+RDEPEND="gtk? ( x11-libs/gtk+:* )
>=sys-apps/pcsc-lite-1.2.9
xpi? ( || ( >=www-client/firefox-bin-3.6.24
>=www-client/firefox-3.6.20 ) )
@@ -35,18 +38,32 @@ RDEPEND="gtk? ( x11-libs/gtk+:2 )
DEPEND="${RDEPEND}
virtual/pkgconfig"
-if [[ ${PV} == "9999" ]]; then
- src_prepare() {
+src_prepare() {
+ use gtk || epatch "${FILESDIR}"/gtk_not_required_${PV}.patch
+
+ if [[ ${PV} == "9999" ]] ; then
+ # Only in current git. Hopefully, in next release.
+ sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac
+ sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in
+ fi
+
+ if [[ ${PV} == "9999" ]] || ! use gtk ; then
eautoreconf
- }
-fi
+ fi
+}
src_configure() {
- econf $(use_enable gtk dialogs) --disable-static
+ econf $(use_enable dialogs) --disable-static
}
src_install() {
emake DESTDIR="${D}" install
+
+ if [[ ${PV} != "9999" ]] ; then
+ # Automatically done in current git. Hopefully, in next release.
+ rm doc/sdk/include/rsaref220/win32.h
+ doheader -r doc/sdk/include/*
+ fi
if use xpi; then
declare MOZILLA_FIVE_HOME
if has_version '>=www-client/firefox-3.6.20'; then