summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-10-11 12:11:10 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-10-11 12:13:54 -0700
commit3d8972647a9f6998fa124a3323d6367ed4757829 (patch)
tree83cd6b993914d4ef03579c929b109c23a71f8316 /app-crypt/minisign
parentapp-crypt/minisign: add 0.10, minor fixes (diff)
downloadgentoo-3d8972647a9f6998fa124a3323d6367ed4757829.tar.gz
gentoo-3d8972647a9f6998fa124a3323d6367ed4757829.tar.bz2
gentoo-3d8972647a9f6998fa124a3323d6367ed4757829.zip
app-crypt/minisign: sync live ebuild
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-crypt/minisign')
-rw-r--r--app-crypt/minisign/minisign-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-crypt/minisign/minisign-9999.ebuild b/app-crypt/minisign/minisign-9999.ebuild
index 6b1c1c8ca147..154ff1cfe795 100644
--- a/app-crypt/minisign/minisign-9999.ebuild
+++ b/app-crypt/minisign/minisign-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
else
SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
LICENSE="ISC"
@@ -21,10 +21,11 @@ SLOT="0"
IUSE=""
-DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/libsodium:=[-minimal]"
RDEPEND="${DEPEND}"
src_configure() {
- local mycmakeargs=( -DCMAKE_STRIP="${EPREFIX}/bin/true" )
+ local mycmakeargs=( -DCMAKE_STRIP=OFF )
cmake_src_configure
}