summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-08 14:43:44 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-08 14:45:20 -0500
commitffe6d5783e93cb4b95c21528112c12c2c8c05a54 (patch)
tree6534583b01dc71512b16eb94ea97c7bc1d9e7eba /app-crypt/pdfcrack/pdfcrack-0.16.ebuild
parentapp-text/qpdf: remove old (diff)
downloadgentoo-ffe6d5783e93cb4b95c21528112c12c2c8c05a54.tar.gz
gentoo-ffe6d5783e93cb4b95c21528112c12c2c8c05a54.tar.bz2
gentoo-ffe6d5783e93cb4b95c21528112c12c2c8c05a54.zip
app-crypt/pdfcrack: version bump to 0.16
Diffstat (limited to 'app-crypt/pdfcrack/pdfcrack-0.16.ebuild')
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.16.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/pdfcrack-0.16.ebuild b/app-crypt/pdfcrack/pdfcrack-0.16.ebuild
new file mode 100644
index 000000000000..206b6b4510de
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.14-cflags.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}