summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-01-25 16:33:25 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-01-25 16:34:18 +0300
commit26e6daed9772c4eec8aabe5ffba0588a0d08fe40 (patch)
tree10af20177d8dcff95c7d109d3b76f0096bb2aa5e /app-crypt/pinentry
parentnet-misc/openssh-8.4_p1-r3: fix compilation on Darwin (diff)
downloadgentoo-26e6daed9772c4eec8aabe5ffba0588a0d08fe40.tar.gz
gentoo-26e6daed9772c4eec8aabe5ffba0588a0d08fe40.tar.bz2
gentoo-26e6daed9772c4eec8aabe5ffba0588a0d08fe40.zip
app-crypt/pinentry: use ESYSROOT properly
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/pinentry-1.1.0-r3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-crypt/pinentry/pinentry-1.1.0-r3.ebuild b/app-crypt/pinentry/pinentry-1.1.0-r3.ebuild
index b1f94a63c96a..a86c83d4d9f6 100644
--- a/app-crypt/pinentry/pinentry-1.1.0-r3.ebuild
+++ b/app-crypt/pinentry/pinentry-1.1.0-r3.ebuild
@@ -67,10 +67,10 @@ src_configure() {
$(use_enable qt5 pinentry-qt) \
$(use_with caps libcap) \
--enable-pinentry-tty \
- FLTK_CONFIG="${EROOT}/usr/bin/fltk-config" \
+ FLTK_CONFIG="${ESYSROOT}/usr/bin/fltk-config" \
MOC="$(qt5_get_bindir)"/moc \
- GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config" \
- LIBASSUAN_CONFIG="${EROOT}/usr/bin/libassuan-config" \
+ GPG_ERROR_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-gpg-error-config" \
+ LIBASSUAN_CONFIG="${ESYSROOT}/usr/bin/libassuan-config" \
$("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
}