summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2024-04-13 16:47:01 -0500
committerSam James <sam@gentoo.org>2024-05-09 21:48:38 +0100
commite7a875ce8edf6fc421eaf1b37a150743bfdb04a0 (patch)
tree04345438da6b87dcb950f4f7b57846a3d411a8b2 /app-crypt/tpm2-pkcs11
parentapp-crypt/tpm2-pkcs11: Add Python 3.12 support (diff)
downloadgentoo-e7a875ce8edf6fc421eaf1b37a150743bfdb04a0.tar.gz
gentoo-e7a875ce8edf6fc421eaf1b37a150743bfdb04a0.tar.bz2
gentoo-e7a875ce8edf6fc421eaf1b37a150743bfdb04a0.zip
app-crypt/tpm2-pkcs11: drop 1.9.0, 1.9.0-r1
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36407 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-pkcs11')
-rw-r--r--app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0-r1.ebuild70
-rw-r--r--app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0.ebuild61
2 files changed, 0 insertions, 131 deletions
diff --git a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0-r1.ebuild b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0-r1.ebuild
deleted file mode 100644
index 9f263b30a998..000000000000
--- a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit autotools python-single-r1
-
-DESCRIPTION="A PKCS#11 interface for TPM2 hardware"
-HOMEPAGE="https://tpm2-software.github.io/"
-SRC_URI="https://github.com/tpm2-software/tpm2-pkcs11/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="fapi test"
-REQUIRED_USE="( ${PYTHON_REQUIRED_USE} )"
-
-# Units tests only for now
-RESTRICT="!test? ( test )"
-
-RDEPEND="${PYTHON_DEPS}
- app-crypt/p11-kit
- app-crypt/tpm2-abrmd
- app-crypt/tpm2-tools[fapi?]
- !fapi? ( app-crypt/tpm2-tss:= )
- fapi? ( >=app-crypt/tpm2-tss-3.0.1:=[fapi] )
- dev-db/sqlite:3
- dev-libs/libyaml
- dev-libs/openssl:=
- $(python_gen_cond_dep '
- dev-python/bcrypt[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/tpm2-pytss[${PYTHON_USEDEP}]
- ')
-"
-
-DEPEND="test? ( dev-util/cmocka )
- ${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}
- dev-build/autoconf-archive
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.9.0-Remove-incorrect-append-in-configure-ac.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable fapi) \
- $(use_enable test unit)
-}
-
-src_install() {
- default
- python_domodule tools/tpm2_pkcs11
- python_newscript tools/tpm2_ptool.py tpm2_ptool
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0.ebuild b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0.ebuild
deleted file mode 100644
index fab1bce25187..000000000000
--- a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit python-single-r1
-
-DESCRIPTION="A PKCS#11 interface for TPM2 hardware"
-HOMEPAGE="https://tpm2-software.github.io/"
-SRC_URI="https://github.com/tpm2-software/tpm2-pkcs11/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="fapi test"
-REQUIRED_USE="( ${PYTHON_REQUIRED_USE} )"
-
-# Units tests only for now
-RESTRICT="!test? ( test )"
-
-RDEPEND="${PYTHON_DEPS}
- app-crypt/p11-kit
- app-crypt/tpm2-abrmd
- app-crypt/tpm2-tools[fapi?]
- !fapi? ( app-crypt/tpm2-tss:= )
- fapi? ( >=app-crypt/tpm2-tss-3.0.1:=[fapi] )
- dev-db/sqlite:3
- dev-libs/libyaml
- dev-libs/openssl:=
- $(python_gen_cond_dep '
- dev-python/bcrypt[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/tpm2-pytss[${PYTHON_USEDEP}]
- ')
-"
-
-DEPEND="test? ( dev-util/cmocka )
- ${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}
- dev-build/autoconf-archive
- virtual/pkgconfig"
-
-src_configure() {
- econf \
- $(use_enable fapi) \
- $(use_enable test unit)
-}
-
-src_install() {
- default
- python_domodule tools/tpm2_pkcs11
- python_newscript tools/tpm2_ptool.py tpm2_ptool
- find "${ED}" -name '*.la' -delete || die
-}