summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-04-13 20:33:43 +0200
committerFabian Groffen <grobian@gentoo.org>2017-04-13 20:33:53 +0200
commit75fd7d4a801fbfce3449e6987f0a58700f8dac98 (patch)
tree44e9e59a182acd69ea8e222bd4d15f53fac327d4 /app-crypt
parentnet-fs/netatalk: Version bump (bug 614420). (diff)
downloadgentoo-75fd7d4a801fbfce3449e6987f0a58700f8dac98.tar.gz
gentoo-75fd7d4a801fbfce3449e6987f0a58700f8dac98.tar.bz2
gentoo-75fd7d4a801fbfce3449e6987f0a58700f8dac98.zip
app-crypt/rhash: fix and keyword for Solaris
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/rhash/rhash-1.3.4.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/app-crypt/rhash/rhash-1.3.4.ebuild b/app-crypt/rhash/rhash-1.3.4.ebuild
index 3a58d6df4345..2be1edde5f31 100644
--- a/app-crypt/rhash/rhash-1.3.4.ebuild
+++ b/app-crypt/rhash/rhash-1.3.4.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86 ~x64-macos ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86 ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="debug nls openssl static-libs"
RDEPEND="openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )"
@@ -29,8 +29,7 @@ src_prepare() {
sed -i -e 's:\$(DESTDIR)/etc:\$(DESTDIR)/$(SYSCONFDIR):g' Makefile || die
if [[ ${CHOST} == *-darwin* ]] ; then
- local
- ver_script='-Wl,--version-script,exports.sym,-soname,$(SONAME)'
+ local ver_script='-Wl,--version-script,exports.sym,-soname,$(SONAME)'
local install_name='-install_name $(LIBDIR)/$(SONAME)'
sed -i -e '/^\(SONAME\|SHAREDLIB\)/s/\.so\.\([0-9]\+\)/.\1.dylib/' \
-e '/^SOLINK/s/\.so/.dylib/' \
@@ -39,6 +38,12 @@ src_prepare() {
Makefile || die
fi
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # https://sourceware.org/bugzilla/show_bug.cgi?id=12548
+ # skip the export.sym for now
+ sed -i -e 's/,--version-script,exports.sym//' librhash/Makefile || die
+ fi
+
multilib_copy_sources
}
@@ -53,7 +58,8 @@ multilib_src_compile() {
$(use openssl && echo -ldl)
)
- [[ ${CHOST} == *-darwin* ]] && ADDLDFLAGS+=( $(use nls && echo -lintl) )
+ [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] \
+ && ADDLDFLAGS+=( $(use nls && echo -lintl) )
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" \
ADDCFLAGS="${ADDCFLAGS[*]}" ADDLDFLAGS="${ADDLDFLAGS[*]}" \