summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-06 16:56:10 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-06 16:57:11 -0600
commit897be22576a166416a7f2b15e757b6690d024d9b (patch)
tree965101170c8c258614b3694b5fadd40a971524a6 /app-crypt
parentnet-im/choqok: Temporary fix for USE !share (diff)
downloadgentoo-897be22576a166416a7f2b15e757b6690d024d9b.tar.gz
gentoo-897be22576a166416a7f2b15e757b6690d024d9b.tar.bz2
gentoo-897be22576a166416a7f2b15e757b6690d024d9b.zip
app-crypt/certbot: fix testing, again
Closes: https://bugs.gentoo.org/708506 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/certbot-1.2.0-r1.ebuild (renamed from app-crypt/certbot/certbot-1.2.0.ebuild)18
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild18
2 files changed, 16 insertions, 20 deletions
diff --git a/app-crypt/certbot/certbot-1.2.0.ebuild b/app-crypt/certbot/certbot-1.2.0-r1.ebuild
index ec673774775d..c81039179f59 100644
--- a/app-crypt/certbot/certbot-1.2.0.ebuild
+++ b/app-crypt/certbot/certbot-1.2.0-r1.ebuild
@@ -38,14 +38,12 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # acme is not installed, removing it here is fine, the dir just confuses tests
- rm -R ../acme
- pytest -vv ${PN} || die
+DEPEND="${CDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # required as deps of deps can trigger this too...
+ echo ' ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
+ distutils-r1_python_prepare_all
}
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index ec673774775d..c81039179f59 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -38,14 +38,12 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # acme is not installed, removing it here is fine, the dir just confuses tests
- rm -R ../acme
- pytest -vv ${PN} || die
+DEPEND="${CDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # required as deps of deps can trigger this too...
+ echo ' ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
+ distutils-r1_python_prepare_all
}