summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-05 19:16:44 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-05 19:16:44 +0200
commit9e6d23d9f5baf23236a6d5a14226a62bd20cfea2 (patch)
tree003d57feba51f20fd79f08ea7f16b6856faff700 /app-crypt
parentwww-servers/varnish: drop 7.1.2-r2 (diff)
downloadgentoo-9e6d23d9f5baf23236a6d5a14226a62bd20cfea2.tar.gz
gentoo-9e6d23d9f5baf23236a6d5a14226a62bd20cfea2.tar.bz2
gentoo-9e6d23d9f5baf23236a6d5a14226a62bd20cfea2.zip
app-crypt/osslsigncode: add 2.8
Closes: https://bugs.gentoo.org/929291 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/osslsigncode/Manifest1
-rw-r--r--app-crypt/osslsigncode/osslsigncode-2.8.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/osslsigncode/Manifest b/app-crypt/osslsigncode/Manifest
index 18c0414964e8..21244fdd489a 100644
--- a/app-crypt/osslsigncode/Manifest
+++ b/app-crypt/osslsigncode/Manifest
@@ -1,5 +1,6 @@
DIST osslsigncode-2.0.tar.gz 57951 BLAKE2B 67057c07bb667a546e3a8abc49e8a20a0ef42ae77edacd2e88486a4357e8e8e789307e1c2abd2e13d18401621ba5607bb42af46ed8451546a26bb6855a07e652 SHA512 aec7b101afd96925fbd70ac67a6752997f0dab3987151c0658e5f011d8a6be6f53518d7a4aba6dff696c722a1e669100143a87d07c3f59364cd62693e9f3e4e5
DIST osslsigncode-2.5.tar.gz 154421 BLAKE2B 44b406f8f2cbac6c89e63ea5aba98e5571e26ecd7f86695879a13199a11025d2689d3e369838cb69c0de7be6c3d06fc7d8709a57ee2132cd25348137d5094417 SHA512 aa491518e6383bad4209616e88cec46e047596afd54067d02be8e7c87030999b6dc715983214e389c2f58fb5b10350b36dfe28e6179b9893fc5266172b2dae01
+DIST osslsigncode-2.8.tar.gz 747274 BLAKE2B 62472d0830b53b2d182b37585a225f0699600bcc2bad5915a64a52b5b7c3fab6f7e936ba82e41907e41c9b0cc1f8ff5f47aa79feb8c5742b16d1fe101baf3db0 SHA512 dd7349e3a64c1d6f63379a14450c8e643c006d2824dc41ce9ecde64ba276466772c440e577aca4a805a49c7ba88aa0dcf5ea73c323abcc4945491407b20e8e96
DIST osslsigncode-test-unsigned.cat 394 BLAKE2B 77a9ebd80feb7ec4f26c0899a760b6463f88ed2301fd3c65c4d72417f7d7d61f0e51c0ca87870500bec51f900aafe05216f4cec888db6c76b292760862da7d00 SHA512 3f4212a4a0822079ba46a90aa80f725d0068bc30e8be057019b2c500633d502f6d879c4ba332c54e1194c148a1fd4d7551a2ba7cb143f2fe53cef5fe94d9364c
DIST osslsigncode-test-unsigned.ex_ 120 BLAKE2B 7036b07cfa8f7d1bcdfc1293671aaa01780bffee0339aa5b63b8db77dd2d77a75ffa51363385c2d40d62d057adf4627afa47f099f8e1206c4eeda67af01bd8fc SHA512 373592e6bffe1da907cfa464fa70d1b64c177beb7fd76325553afb0d721263d35b40508e3ede0a64bd016abb2ce97e104417fa472cd2bb0d92f5d14d5001349c
DIST osslsigncode-test-unsigned.exe 96150 BLAKE2B fd0da9e64473fed792572606f38de8c71e285a557883ac29201b113abc533a32c80ed17330860dd30b9913302ea44433c41d21ba236789ed6d25083f5909960b SHA512 afed867e6a680d7bdfe27e537ccf6496572d79b8b8a90e1886a83d9b8a67c815a54b7bd929819a0cab7b3243c276dd676e51b267a918ace448689d4b424d948b
diff --git a/app-crypt/osslsigncode/osslsigncode-2.8.ebuild b/app-crypt/osslsigncode/osslsigncode-2.8.ebuild
new file mode 100644
index 000000000000..9d9e80561854
--- /dev/null
+++ b/app-crypt/osslsigncode/osslsigncode-2.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+#OSSLSIGNCODE_TEST_FILES=( unsigned.{cat,ex_,exe,msi} )
+inherit cmake python-any-r1
+
+DESCRIPTION="Platform-independent tool for Authenticode signing of EXE/CAB files"
+HOMEPAGE="https://github.com/mtrojnar/osslsigncode"
+SRC_URI="https://github.com/mtrojnar/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+for test_file in "${OSSLSIGNCODE_TEST_FILES[@]}" ; do
+ SRC_URI+=" test? ( https://github.com/mtrojnar/osslsigncode/raw/${PV}/tests/files/${test_file} -> ${PN}-test-${test_file} )"
+done
+unset test_file
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl test"
+#RESTRICT="!test? ( test )"
+# https://github.com/mtrojnar/osslsigncode/issues/140#issuecomment-1060636197
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/openssl:=
+ sys-libs/zlib:=
+ curl? ( net-misc/curl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ ${PYTHON_DEPS}
+ sys-libs/libfaketime
+ )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if use test ; then
+ local test_file
+ for test_file in "${OSSLSIGNCODE_TEST_FILES[@]}" ; do
+ cp "${DISTDIR}"/${PN}-test-${test_file} tests/files/${test_file} || die
+ done
+ unset test_file
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package curl CURL)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_src_test -j1
+}