summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-01 16:32:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-01 16:35:09 -0500
commitab1ffc63c021bbf1de0b66e75e53f8bd76eee76b (patch)
tree12568b358058748a5f2aef3f85041f27ea122a8f /app-crypt
parentapp-crypt/certbot-nginx: add DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-ab1ffc63c021bbf1de0b66e75e53f8bd76eee76b.tar.gz
gentoo-ab1ffc63c021bbf1de0b66e75e53f8bd76eee76b.tar.bz2
gentoo-ab1ffc63c021bbf1de0b66e75e53f8bd76eee76b.zip
app-crypt/certbot-apache: switch to using DISTUTILS_USE_SETUPTOOLS
closes: https://bugs.gentoo.org/745855 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.7.0.ebuild4
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild4
-rw-r--r--app-crypt/certbot-apache/certbot-apache-9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-1.7.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.7.0.ebuild
index ae20aed95bb9..2977a0aff13d 100644
--- a/app-crypt/certbot-apache/certbot-apache-1.7.0.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-1.7.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -30,8 +31,7 @@ RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
esetup.py test || die
diff --git a/app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild
index 323d9f35ff3a..3a367b955f0a 100644
--- a/app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -30,8 +31,7 @@ RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
esetup.py test || die
diff --git a/app-crypt/certbot-apache/certbot-apache-9999.ebuild b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
index 323d9f35ff3a..3a367b955f0a 100644
--- a/app-crypt/certbot-apache/certbot-apache-9999.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -30,8 +31,7 @@ RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
esetup.py test || die