summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-03 00:17:06 +0100
committerSam James <sam@gentoo.org>2023-05-03 00:17:45 +0100
commitc81ec24be475a4a950db2f783b8edf845b53ed4b (patch)
tree93ab2a46fa6fc74caca5921c92f53c80ed1466a8 /app-crypt
parentapp-crypt/acme: fix pyopenssl dep (diff)
downloadgentoo-c81ec24be475a4a950db2f783b8edf845b53ed4b.tar.gz
gentoo-c81ec24be475a4a950db2f783b8edf845b53ed4b.tar.bz2
gentoo-c81ec24be475a4a950db2f783b8edf845b53ed4b.zip
app-crypt/certbot-nginx: fix pyopenssl dep
This leads to confusing portage output because blockers shouldn't be used unless there's a file collision. Just >=dep on the latest stable pyopenssl instead to keep it simple. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-2.5.0-r1.ebuild (renamed from app-crypt/certbot-nginx/certbot-nginx-2.5.0.ebuild)5
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/app-crypt/certbot-nginx/certbot-nginx-2.5.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-2.5.0-r1.ebuild
index 8f87e5994fac..681a2d89b66e 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-2.5.0.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-2.5.0-r1.ebuild
@@ -40,11 +40,12 @@ BDEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
+# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
+# to avoid broken 23.1.0.
RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
>=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
- !~dev-python/pyopenssl-23.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
index 8f87e5994fac..681a2d89b66e 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -40,11 +40,12 @@ BDEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
+# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
+# to avoid broken 23.1.0.
RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
>=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
- !~dev-python/pyopenssl-23.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
"