summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-dicts/wordnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-dicts/wordnet')
-rw-r--r--app-dicts/wordnet/Manifest2
-rw-r--r--app-dicts/wordnet/files/wordnet-3.0-format-security.patch48
-rw-r--r--app-dicts/wordnet/files/wordnet-3.0-src_stubs_c.patch12
-rw-r--r--app-dicts/wordnet/files/wordnet-3.0-tcl8.6.patch133
-rw-r--r--app-dicts/wordnet/metadata.xml7
-rw-r--r--app-dicts/wordnet/wordnet-3.0-r4.ebuild71
6 files changed, 273 insertions, 0 deletions
diff --git a/app-dicts/wordnet/Manifest b/app-dicts/wordnet/Manifest
new file mode 100644
index 000000000000..0c1ab1f84396
--- /dev/null
+++ b/app-dicts/wordnet/Manifest
@@ -0,0 +1,2 @@
+DIST WordNet-3.0.tar.gz 11537227 SHA256 b4d8b1feeb22defe686cf1c5062d723bd854997614da9547fa135e5137843531 SHA512 d39c008cec41de8f1b2aeacb4ad818f9997a13b30a992fda100b6dcc9c11c253530b00a1909b55ff7b564bafc33f7763c1ce9b0a6ae3e591695db2083e9ead7a WHIRLPOOL cfba84209b4366b1ab381957f82cc2a32039d073baf8fbd44252c829c9291be76f05b214e014157f3ec03a354aaec68a14e20103dde37d11f13b846056aa90f4
+DIST wordnet-3.0-patchset-1.tar.bz2 8076 SHA256 d8333b107f53e188981e9ec0e1e53890c8bd7155924ae140c777c3f443d8aba7 SHA512 17668d736dd6dfe83e4d5d328729cbcdfb4dbca9a9707651534169bd2ce6fc2238d5c820d63330c51c20ab9b2964b56a609f58242b05dabbcfdfc0da61c048cb WHIRLPOOL 30e3820c2679148206bc14d5acf8eb7a2bde422f13ce2e9b0a90145e510667d70b1c1ef5d3486c85eddf6492c72b2243672683164f917f8ff5910370e30bd0f8
diff --git a/app-dicts/wordnet/files/wordnet-3.0-format-security.patch b/app-dicts/wordnet/files/wordnet-3.0-format-security.patch
new file mode 100644
index 000000000000..b5d86dbbdd89
--- /dev/null
+++ b/app-dicts/wordnet/files/wordnet-3.0-format-security.patch
@@ -0,0 +1,48 @@
+ lib/binsrch.c | 4 ++--
+ src/wn.c | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/lib/binsrch.c b/lib/binsrch.c
+index 8b71216..9ac51a7 100644
+--- a/lib/binsrch.c
++++ b/lib/binsrch.c
+@@ -193,7 +193,7 @@ char *replace_line(char *new_line, char *searchkey, FILE *fp)
+ copyfile(fp, tfp);
+ if (fseek(fp, offset, 0) == -1)
+ return(NULL); /* could not seek to offset */
+- fprintf(fp, new_line); /* write line */
++ fprintf(fp, "%s", new_line); /* write line */
+ rewind(tfp);
+ copyfile(tfp, fp);
+
+@@ -220,7 +220,7 @@ char *insert_line(char *new_line, char *searchkey, FILE *fp)
+ copyfile(fp, tfp);
+ if (fseek(fp, offset, 0) == -1)
+ return(NULL); /* could not seek to offset */
+- fprintf(fp, new_line); /* write line */
++ fprintf(fp, "%s", new_line); /* write line */
+ rewind(tfp);
+ copyfile(tfp, fp);
+
+diff --git a/src/wn.c b/src/wn.c
+index 004e1e6..398632f 100644
+--- a/src/wn.c
++++ b/src/wn.c
+@@ -284,7 +284,7 @@ static void printsearches(char *word, int dbase, unsigned long search)
+ printf("\t");
+ printf(searchstr[j].template,
+ partchars[dbase], partchars[dbase]);
+- printf(searchstr[j].helpstr);
++ printf("%s", searchstr[j].helpstr);
+ printf("\n");
+ }
+ }
+@@ -345,7 +345,7 @@ static int getoptidx(char *searchtype)
+
+ static int error_message(char *msg)
+ {
+- fprintf(stderr, msg);
++ fprintf(stderr, "%s", msg);
+ return(0);
+ }
+
diff --git a/app-dicts/wordnet/files/wordnet-3.0-src_stubs_c.patch b/app-dicts/wordnet/files/wordnet-3.0-src_stubs_c.patch
new file mode 100644
index 000000000000..29c42dea9c35
--- /dev/null
+++ b/app-dicts/wordnet/files/wordnet-3.0-src_stubs_c.patch
@@ -0,0 +1,12 @@
+diff -urNad wordnet-3.0/src/stubs.c.orig wordnet-3.0/src/stubs.c
+--- wordnet-3.0/src/stubs.c.orig 2007-01-04 18:47:55.000000000 +0100
++++ wordnet-3.0/src/stubs.c 2007-01-20 19:01:19.000000000 +0100
+@@ -14,7 +14,7 @@
+ #include <tk.h>
+ #include <wn.h>
+
+-static char *Id = "$Id: stubs.c,v 1.7 2005/04/29 19:01:57 wn Exp $";
++static const char Id[] = "$Id: stubs.c,v 1.7 2005/04/29 19:01:57 wn Exp $";
+
+ static char resultbuf[SEARCHBUF];
+
diff --git a/app-dicts/wordnet/files/wordnet-3.0-tcl8.6.patch b/app-dicts/wordnet/files/wordnet-3.0-tcl8.6.patch
new file mode 100644
index 000000000000..110ffc2110b8
--- /dev/null
+++ b/app-dicts/wordnet/files/wordnet-3.0-tcl8.6.patch
@@ -0,0 +1,133 @@
+ src/stubs.c | 33 +++++++++++++++++----------------
+ 1 file changed, 17 insertions(+), 16 deletions(-)
+
+diff --git a/src/stubs.c b/src/stubs.c
+index 794485c..cec2c04 100644
+--- a/src/stubs.c
++++ b/src/stubs.c
+@@ -40,8 +40,8 @@ int wn_findvalidsearches (ClientData clientData, Tcl_Interp *interp,
+ char *morph;
+ int pos;
+ if (argc != 3) {
+- interp -> result =
+- "usage: findvalidsearches searchword partofspeechnum";
++ Tcl_SetResult(interp,
++ "usage: findvalidsearches searchword partofspeechnum", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ pos = atoi (argv[2]);
+@@ -52,7 +52,7 @@ int wn_findvalidsearches (ClientData clientData, Tcl_Interp *interp,
+ } while ((morph = morphstr (NULL, pos)) != NULL);
+ }
+ sprintf (bitfieldstr, "%u", bitfield);
+- interp -> result = bitfieldstr;
++ Tcl_SetResult(interp, bitfieldstr, TCL_STATIC);
+ return TCL_OK;
+ }
+
+@@ -69,13 +69,13 @@ int wn_bit (ClientData clientData, Tcl_Interp *interp,
+ static char bitfieldstr[32];
+ int whichbit;
+ if (argc != 2) {
+- interp -> result = "usage: bit bitnum";
++ Tcl_SetResult(interp, "usage: bit bitnum", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ whichbit = atoi (argv[1]);
+ bitfield = bit (whichbit);
+ sprintf (bitfieldstr, "%u", bitfield);
+- interp -> result = bitfieldstr;
++ Tcl_SetResult(interp, bitfieldstr, TCL_STATIC);
+ return TCL_OK;
+ }
+
+@@ -89,8 +89,8 @@ int wn_search (ClientData clientData, Tcl_Interp *interp,
+ int pos, searchtype, sense;
+ char *morph;
+ if (argc != 5) {
+- interp -> result =
+- "usage: search searchword partofspeechnum searchtypenum sensenum";
++ Tcl_SetResult(interp,
++ "usage: search searchword partofspeechnum searchtypenum sensenum", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ pos = atoi (argv[2]);
+@@ -102,7 +102,7 @@ int wn_search (ClientData clientData, Tcl_Interp *interp,
+ strcat (resultbuf, findtheinfo (morph, pos, searchtype, sense));
+ } while ((morph = morphstr (NULL, pos)) != NULL);
+ }
+- interp -> result = resultbuf;
++ Tcl_SetResult(interp, resultbuf, TCL_STATIC);
+ return TCL_OK;
+ }
+
+@@ -114,7 +114,7 @@ int wn_search (ClientData clientData, Tcl_Interp *interp,
+ int wn_glosses (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 2) {
+- interp -> result = "usage: glosses [1 | 0]";
++ Tcl_SetResult(interp, "usage: glosses [1 | 0]", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ dflag = atoi (argv[1]);
+@@ -129,7 +129,7 @@ int wn_glosses (ClientData clientData, Tcl_Interp *interp,
+ int wn_fileinfo (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 2) {
+- interp -> result = "usage: fileinfo [1 | 0]";
++ Tcl_SetResult(interp, "usage: fileinfo [1 | 0]", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ fileinfoflag = atoi (argv[1]);
+@@ -144,7 +144,7 @@ int wn_fileinfo (ClientData clientData, Tcl_Interp *interp,
+ int wn_byteoffset (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 2) {
+- interp -> result = "usage: byteoffset [1 | 0]";
++ Tcl_SetResult(interp, "usage: byteoffset [1 | 0]", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ offsetflag = atoi (argv[1]);
+@@ -159,7 +159,7 @@ int wn_byteoffset (ClientData clientData, Tcl_Interp *interp,
+ int wn_senseflag (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 2) {
+- interp -> result = "usage: senseflag [1 | 0]";
++ Tcl_SetResult(interp, "usage: senseflag [1 | 0]", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ wnsnsflag = atoi (argv[1]);
+@@ -175,12 +175,13 @@ int wn_contextualhelp (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ int pos, searchtype;
+ if (argc != 3) {
+- interp -> result = "usage: contextualhelp partofspeechnum searchtypenum";
++ Tcl_SetResult(interp,
++ "usage: contextualhelp partofspeechnum searchtypenum", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ pos = atoi (argv[1]);
+ searchtype = atoi (argv[2]);
+- interp -> result = helptext[pos][searchtype];
++ Tcl_SetResult(interp, helptext[pos][searchtype], TCL_STATIC);
+ return TCL_OK;
+ }
+
+@@ -190,7 +191,7 @@ int wn_contextualhelp (ClientData clientData, Tcl_Interp *interp,
+ int wn_reopendb (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 1) {
+- interp -> result = "usage: reopendb";
++ Tcl_SetResult(interp, "usage: reopendb", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ re_wninit ();
+@@ -204,7 +205,7 @@ int wn_reopendb (ClientData clientData, Tcl_Interp *interp,
+ int wn_abortsearch (ClientData clientData, Tcl_Interp *interp,
+ int argc, char *argv[]) {
+ if (argc != 1) {
+- interp -> result = "usage: abortsearch";
++ Tcl_SetResult(interp, "usage: abortsearch", TCL_STATIC);
+ return TCL_ERROR;
+ }
+ abortsearch = 1;
diff --git a/app-dicts/wordnet/metadata.xml b/app-dicts/wordnet/metadata.xml
new file mode 100644
index 000000000000..1470e032181b
--- /dev/null
+++ b/app-dicts/wordnet/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-dicts/wordnet/wordnet-3.0-r4.ebuild b/app-dicts/wordnet/wordnet-3.0-r4.ebuild
new file mode 100644
index 000000000000..c23524b5ba54
--- /dev/null
+++ b/app-dicts/wordnet/wordnet-3.0-r4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="A lexical database for the English language"
+HOMEPAGE="http://wordnet.princeton.edu/"
+SRC_URI="
+ ftp://ftp.cogsci.princeton.edu/pub/wordnet/${PV}/WordNet-${PV}.tar.gz
+ mirror://gentoo/${P}-patchset-1.tar.bz2"
+LICENSE="Princeton"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+# In contrast to what the configure script seems to imply, Tcl/Tk is NOT optional.
+# cf. bug 163478 for details. (Yes, it's about 2.1 but it's still the same here.)
+DEPEND="
+ dev-lang/tcl:0=
+ dev-lang/tk:0="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/WordNet-${PV}"
+
+PATCHES=(
+ # Don't install into PREFIX/dict but PREFIX/share/wordnet/dict
+ "${WORKDIR}/${P}-dict-location.patch"
+ # Fixes bug 130024, make an additional shared lib
+ "${WORKDIR}/${P}-shared-lib.patch"
+ # Don't install the docs directly into PREFIX/doc but PREFIX/doc/PN
+ "${WORKDIR}/${P}-docs-path.patch"
+ "${WORKDIR}"/${P}-CVE-2008-3908.patch #211491
+ "${WORKDIR}"/${P}-CVE-2008-2149.patch #211491
+
+ "${FILESDIR}"/${P}-tcl8.6.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-src_stubs_c.patch
+)
+src_prepare() {
+ epatch ${PATCHES[@]}
+ # Don't install all the extra docs (html, pdf, ps) without doc USE flag.
+ if ! use doc; then
+ sed -i -e "s:SUBDIRS =.*:SUBDIRS = man:" doc/Makefile.am || die
+ fi
+
+ # Drop installation of OLD tk.h headers #255590
+ sed '/^SUBDIRS/d' -i include/Makefile.am || die
+ sed 's: include/tk/Makefile::' -i configure.ac || die
+ rm -rf include/tk/ || die
+
+ rm -f configure || die
+ eautoreconf
+ MAKEOPTS+=" -e"
+}
+
+src_configure() {
+ append-cppflags -DUNIX -I"${T}"/usr/include
+
+ PLATFORM=linux WN_ROOT="${T}/usr" \
+ WN_DICTDIR="${T}/usr/share/wordnet/dict" \
+ WN_MANDIR="${T}/usr/share/man" \
+ WN_DOCDIR="${T}/usr/share/doc/wordnet-${PV}" \
+ WNHOME="${EPREFIX}/usr/share/wordnet" \
+ econf \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ --with-tk="${EPREFIX}"/usr/$(get_libdir)
+}