summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-doc/halibut
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-doc/halibut')
-rw-r--r--app-doc/halibut/Manifest2
-rw-r--r--app-doc/halibut/halibut-1.0.ebuild33
-rw-r--r--app-doc/halibut/halibut-1.1.ebuild35
-rw-r--r--app-doc/halibut/metadata.xml8
4 files changed, 78 insertions, 0 deletions
diff --git a/app-doc/halibut/Manifest b/app-doc/halibut/Manifest
new file mode 100644
index 000000000000..f7ce296dde11
--- /dev/null
+++ b/app-doc/halibut/Manifest
@@ -0,0 +1,2 @@
+DIST halibut-1.0.tar.gz 940897 SHA256 0d039adb88cb8de6f350563514d013209c2d321d1e5c49ea56462c6803f29adb SHA512 9651ac0611060971f8b5412f6456e4e85b3107c90e7fab3352294b8c3de17dfa4935b86ec23a6431ee821b26d2d5fd2addf1114e69026d714bc9d9f94a79e12c WHIRLPOOL 99cfee05b66c7c81375f47edd6342b34e43d9019a82ab4ba5443a1ef7b2b7dc69bfdc321f6c7026ebb8cca6d2cff78ad3107232ac432939d81427646e632a413
+DIST halibut-1.1.tar.gz 956743 SHA256 b964950d11ed09d3af28ac095da539613f6e50d650f01fe72b4ae752724c80a0 SHA512 01b0563ebb3678dc1ff1cef1d752d5ebffed70ef73a10d8266d84da3b4401006b686104bbe3e1984ebd3a54254f16d008011b3be8c29a3b9f1e3a033d61cdb15 WHIRLPOOL bc4b20fb9c4bb60db0c75a9009d913b694fad445674e4e7ded6388cdcc18e1386b4744835a11588daf412dddbc9b6a5a436f294db8b4c0d801f39245b9bc6d5a
diff --git a/app-doc/halibut/halibut-1.0.ebuild b/app-doc/halibut/halibut-1.0.ebuild
new file mode 100644
index 000000000000..d8f432840ff9
--- /dev/null
+++ b/app-doc/halibut/halibut-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="yet another free document preparation system"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/halibut/"
+SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ emake -j1 \
+ BUILDDIR="${S}/build" \
+ VERSION="${PV}" \
+ || die "make failed"
+
+ emake -C doc || die "make in doc failed"
+}
+
+src_install() {
+ dobin build/halibut || die
+ doman doc/halibut.1 || die
+ dodoc doc/halibut.txt
+ dohtml doc/*.html
+}
diff --git a/app-doc/halibut/halibut-1.1.ebuild b/app-doc/halibut/halibut-1.1.ebuild
new file mode 100644
index 000000000000..b117ed084688
--- /dev/null
+++ b/app-doc/halibut/halibut-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="yet another free document preparation system"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/halibut/"
+SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ emake -j1 \
+ BUILDDIR="${S}/build" \
+ VERSION="${PV}" \
+ || die "make failed"
+
+ emake -C doc || die "make in doc failed"
+}
+
+src_install() {
+ dobin build/halibut || die
+ doman doc/halibut.1 || die
+ dodoc doc/halibut.txt
+ dohtml doc/*.html
+}
diff --git a/app-doc/halibut/metadata.xml b/app-doc/halibut/metadata.xml
new file mode 100644
index 000000000000..d67a15ac1284
--- /dev/null
+++ b/app-doc/halibut/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+</maintainer>
+</pkgmetadata>