summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans Fredrik Nordhaug <hansfn@gmail.com>2021-12-22 09:37:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-01-12 18:40:19 +0200
commit4045ba4373e50451e2f30a656deff4140fd13ab7 (patch)
treea8fe780c7bba6252bd02ee281a76a4c2a70798b8 /app-editors/featherpad/featherpad-1.1.0.ebuild
parentnet-libs/libbtbb: Drop 2018.12.1, EAPI6-- (diff)
downloadgentoo-4045ba4373e50451e2f30a656deff4140fd13ab7.tar.gz
gentoo-4045ba4373e50451e2f30a656deff4140fd13ab7.tar.bz2
gentoo-4045ba4373e50451e2f30a656deff4140fd13ab7.zip
app-editors/featherpad: Bump to 1.1.0
Also removed 0.18.0. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans Fredrik Nordhaug <hansfn@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23470 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/featherpad/featherpad-1.1.0.ebuild')
-rw-r--r--app-editors/featherpad/featherpad-1.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/featherpad/featherpad-1.1.0.ebuild b/app-editors/featherpad/featherpad-1.1.0.ebuild
new file mode 100644
index 000000000000..dd562f11fb34
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+X"
+
+RDEPEND="app-text/hunspell:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}