summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-06-06 10:22:53 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-06-06 10:22:53 +0300
commit0e9c2d76e38afe9ed2633f7048515a3e055d59b9 (patch)
treea6ef78cd78f541f7094103e1aecfdf6e6b8c0a87 /app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild
parentprofiles: add GOPATH to ENV_UNSET in the base profile (diff)
downloadgentoo-0e9c2d76e38afe9ed2633f7048515a3e055d59b9.tar.gz
gentoo-0e9c2d76e38afe9ed2633f7048515a3e055d59b9.tar.bz2
gentoo-0e9c2d76e38afe9ed2633f7048515a3e055d59b9.zip
app-editors/kakoune: bump to 2020-06-01 snapshot
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild b/app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild
new file mode 100644
index 000000000000..12ea301be41c
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2020.01.16_p20200601.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_COMMIT="6fa26b8dd2ac0931fe688370728c47086277d883"
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+DEPEND="sys-libs/ncurses:0=[unicode]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/kakoune-2020.01.16-enable-ebuild-syntax-highlight.patch )
+
+S="${WORKDIR}/kakoune-${MY_COMMIT}"
+
+src_configure() { :; }
+
+src_compile() {
+ cd src/ || die
+ emake all
+}
+
+src_test() {
+ cd src/ || die
+ emake test
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr docdir="${D}/usr/share/doc/${PF}" install
+
+ rm "${D}/usr/share/man/man1/kak.1.gz" || die
+ doman doc/kak.1
+}