summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Bayliss <cjbdev@icloud.com>2024-06-28 11:00:05 +1000
committerJoonas Niilola <juippis@gentoo.org>2024-07-23 11:47:03 +0300
commita3c8bb5e2a60331d155650c9a80492d0ab8caa92 (patch)
treef1451c14180adce7d82cafe13b5dd6844b34d9c1 /app-editors/kakoune
parentgnome-extra/gnome-calculator: Fix VariableOrderWrong (diff)
downloadgentoo-a3c8bb5e2a60331d155650c9a80492d0ab8caa92.tar.gz
gentoo-a3c8bb5e2a60331d155650c9a80492d0ab8caa92.tar.bz2
gentoo-a3c8bb5e2a60331d155650c9a80492d0ab8caa92.zip
app-editors/kakoune: add 2024.05.18
Signed-off-by: Christopher Bayliss <cjbdev@icloud.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/kakoune')
-rw-r--r--app-editors/kakoune/Manifest1
-rw-r--r--app-editors/kakoune/kakoune-2024.05.18.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/kakoune/Manifest b/app-editors/kakoune/Manifest
index 27da3bad8af1..cb0b5f9cafe8 100644
--- a/app-editors/kakoune/Manifest
+++ b/app-editors/kakoune/Manifest
@@ -1,2 +1,3 @@
DIST kakoune-2022.10.31.tar.bz2 556473 BLAKE2B 36489de5e4fa4406a847f43bf0f966c082e5c4a97e3c31d04c61fb8c4137fed4b6d1ce96ac921a85dc03fe7b90d8de172b6720ac32846507a3d0c996fe01191c SHA512 9a02a1a6bbb0b71a579b0286b4dfb6359b856183862b3e17354d2685b8215fa24c196b570a21dfd627e3d5a5b91e20ce0b74caff19e5772ab911cc42677bf720
DIST kakoune-2023.08.05.tar.bz2 568612 BLAKE2B bbedc16f361a242c4319a852c3b688186e1e2b204990aff8434ad8a169d4c62171d2d3424e3bf65a4b5b6b17e21205e84077198091687094f88235e27c544bbd SHA512 f29b787ab6f04bc5a1a3ab31d189128745c967b5eec15fce07ae7dbaf29247f7413499d9925cf0561173feb0fe634f3423ac43da0d6c1ba5d679ee38b80ac679
+DIST kakoune-2024.05.18.tar.bz2 588347 BLAKE2B 3c551d1ccdccbfcc64e52d5e4b32e37f2d4f68188ac3aedd651bfc0af9324c458992eff79d37c2f5ec58135b0923aecfb8d1308be3d6878fe15c8b44fcbd6472 SHA512 4feba6b9a75fd16c1c8151139ac5a98d113f2ab1a5c9e7d03ac194d9d6d67d7dfa25b4e6073546b8dafa241de5db4ddbce4405faa42d710bbc9200f3fab12e4b
diff --git a/app-editors/kakoune/kakoune-2024.05.18.ebuild b/app-editors/kakoune/kakoune-2024.05.18.ebuild
new file mode 100644
index 000000000000..53e54382a0cd
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2024.05.18.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ sed -i '/CXXFLAGS-debug-no = -O3 -g3/d' Makefile || die
+ default
+}
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake all
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr docdir="${ED}/usr/share/doc/${PF}" install
+
+ rm "${ED}/usr/share/man/man1/kak.1.gz" || die
+ doman doc/kak.1
+}