summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongsu Park <dpark@linux.microsoft.com>2022-01-27 17:23:03 +0100
committerSam James <sam@gentoo.org>2022-02-18 02:53:29 +0000
commit49adc5f0272e40ac608a89d268ee12811fcca384 (patch)
tree25572fce7ab725074b5837c97e17558c74b6b6ec /app-editors/vim
parentapp-emulation/xen-tools: drop old (diff)
downloadgentoo-49adc5f0272e40ac608a89d268ee12811fcca384.tar.gz
gentoo-49adc5f0272e40ac608a89d268ee12811fcca384.tar.bz2
gentoo-49adc5f0272e40ac608a89d268ee12811fcca384.zip
app-editors/vim: install defaults.vim only if the file is not installed
Install defaults.vim only if the file is not installed already from vim-core. That's needed for avoiding conflicts between vim and vim-core. Closes: https://bugs.gentoo.org/830177 Signed-off-by: Dongsu Park <dpark@linux.microsoft.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/vim-8.2.0814-r100.ebuild6
-rw-r--r--app-editors/vim/vim-8.2.3428-r1.ebuild6
-rw-r--r--app-editors/vim/vim-8.2.3567.ebuild6
-rw-r--r--app-editors/vim/vim-8.2.3582.ebuild6
-rw-r--r--app-editors/vim/vim-8.2.3669.ebuild6
-rw-r--r--app-editors/vim/vim-8.2.3741.ebuild6
-rw-r--r--app-editors/vim/vim-8.2.3950.ebuild6
-rw-r--r--app-editors/vim/vim-9999.ebuild6
8 files changed, 32 insertions, 16 deletions
diff --git a/app-editors/vim/vim-8.2.0814-r100.ebuild b/app-editors/vim/vim-8.2.0814-r100.ebuild
index 0f20c926a800..11f77d9c3dee 100644
--- a/app-editors/vim/vim-8.2.0814-r100.ebuild
+++ b/app-editors/vim/vim-8.2.0814-r100.ebuild
@@ -306,8 +306,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop
diff --git a/app-editors/vim/vim-8.2.3428-r1.ebuild b/app-editors/vim/vim-8.2.3428-r1.ebuild
index 6a4b59f53ef1..0b57137c4a67 100644
--- a/app-editors/vim/vim-8.2.3428-r1.ebuild
+++ b/app-editors/vim/vim-8.2.3428-r1.ebuild
@@ -318,8 +318,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop
diff --git a/app-editors/vim/vim-8.2.3567.ebuild b/app-editors/vim/vim-8.2.3567.ebuild
index 3ce917bf8851..a16ecf652266 100644
--- a/app-editors/vim/vim-8.2.3567.ebuild
+++ b/app-editors/vim/vim-8.2.3567.ebuild
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop
diff --git a/app-editors/vim/vim-8.2.3582.ebuild b/app-editors/vim/vim-8.2.3582.ebuild
index a17b74f24534..62135009f599 100644
--- a/app-editors/vim/vim-8.2.3582.ebuild
+++ b/app-editors/vim/vim-8.2.3582.ebuild
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop
diff --git a/app-editors/vim/vim-8.2.3669.ebuild b/app-editors/vim/vim-8.2.3669.ebuild
index 3ce917bf8851..a16ecf652266 100644
--- a/app-editors/vim/vim-8.2.3669.ebuild
+++ b/app-editors/vim/vim-8.2.3669.ebuild
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop
diff --git a/app-editors/vim/vim-8.2.3741.ebuild b/app-editors/vim/vim-8.2.3741.ebuild
index 08b5ddc82130..53e69aee9488 100644
--- a/app-editors/vim/vim-8.2.3741.ebuild
+++ b/app-editors/vim/vim-8.2.3741.ebuild
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop
diff --git a/app-editors/vim/vim-8.2.3950.ebuild b/app-editors/vim/vim-8.2.3950.ebuild
index a15f1260d55d..2b7c3b0992cc 100644
--- a/app-editors/vim/vim-8.2.3950.ebuild
+++ b/app-editors/vim/vim-8.2.3950.ebuild
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 3ce917bf8851..a16ecf652266 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop