summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2022-08-11 12:01:09 -0700
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-12 09:38:55 +0300
commit28fc8c7ca35baae3cbe41406c10a0b3846be70bf (patch)
treed61719609b71ef3570babb668f0577e5510aeafb /app-editors
parentapp-editors/vscode: drop 1.69.2 (diff)
downloadgentoo-28fc8c7ca35baae3cbe41406c10a0b3846be70bf.tar.gz
gentoo-28fc8c7ca35baae3cbe41406c10a0b3846be70bf.tar.bz2
gentoo-28fc8c7ca35baae3cbe41406c10a0b3846be70bf.zip
app-editors/vscodium: bump to 1.70.1
Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.70.1.ebuild114
2 files changed, 117 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 2f6ebe8af321..3c906ac4e562 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.69.2-arm64.tar.gz 118959353 BLAKE2B e9a81f208babb84560f391e2a1ee
DIST vscodium-1.70.0-amd64.tar.gz 119473836 BLAKE2B 278b071006de89408f5124a38b0dbccaffa10a574397473ba84da41d0f14ec1b472ffbaef6580cc5a033187aecb9d8de39893d0060e3d16e38741840b57a209f SHA512 d0284e25144c01aeebda8e460d5f83aa62a529bc9c97949f037de9515ad387c3b99ff306eafdeb1a2d69a18a90ba284d7acbbfcb469438ba38a9094b9c55bda2
DIST vscodium-1.70.0-arm.tar.gz 101286329 BLAKE2B aa1862aac41bfcc1836a91933185097abf24664b1a85008603bd0d41154cdcfdf94ae6e9c5885d2762a7b00bbddae5af91f78233f5775c213925992db9969882 SHA512 9565c6c08c6c1dfb8bc1622514eb54220b2453cf697a3f30b85fe67fca9f7a295a525590c5e1b6fa23e9c84f139e54d2425e13c68d872a5a7eb001b945ae5a63
DIST vscodium-1.70.0-arm64.tar.gz 117321647 BLAKE2B 9a49aa9d77dd2aec1561ff8332953062341fc5c6d37e2130c509941d673c2ff32b490ca6755602b46e635425cc801492ed30a058ef8b5f93b58a9c7619695512 SHA512 da82950cf243bbafebb415bf72127edc63dfa805cb37045c5ffff67f24d28fb811c44aa0d2c3b14098238dbd55c29e384872594ef6d8464af95dea6379cdd071
+DIST vscodium-1.70.1-amd64.tar.gz 119463559 BLAKE2B 735786acd7796445f66dea016d3024286c5043f5eda635963eb9dcf4fcb0ff27265aacce18d9e2be00f2f7e6ff580d0c6dc83ac91dbdb7ffd934b721c221793a SHA512 115b3f520b53becbd164c868406805e6012b51414d803283d80eb4cf992c2e0fea53af3e1939dcd9cfb1264b13b4a3eb422a89f763f8eb7fbd28ce462f3a6fd6
+DIST vscodium-1.70.1-arm.tar.gz 101292517 BLAKE2B a2a0abd470988f649d657498ebdb49c1b10ecae4a8797d78da341c526604596680af301a7bb940bcc627e6aaa6fe971a50e4311baf2364fce4eb65779ef835e3 SHA512 33dd3eda80b9a6353e72ed92ee5f2adc3bdc48c49de0fa0829195e695fdfab0cd2fcba9fa1d6a0d6e3eccc3cd4b5c87a86af5e29161105a070f4743a413d7a2a
+DIST vscodium-1.70.1-arm64.tar.gz 117318425 BLAKE2B 16af0105d270aa706d762f94190838f7a0f5fb9ffe3c1b0eccbdf120d8ff1c21473d871170b252e1a805ed9ce81d35f1bcfbc33cd085b363497f40770fb32457 SHA512 9cb90d5a43aa124bc77cdf2868b45da59fa2c8573333373a6e351f2ed00fbccf7069655e30ce39e7322d8c18bb7edb20818b781bc1d60c3f524f8b37b85a6645
diff --git a/app-editors/vscodium/vscodium-1.70.1.ebuild b/app-editors/vscodium/vscodium-1.70.1.ebuild
new file mode 100644
index 000000000000..34c1107537e0
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.70.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-crypt/libsecret[crypt]
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+}