summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-01-30 19:16:32 +0100
committerUlrich Müller <ulm@gentoo.org>2024-01-30 19:30:45 +0100
commit318644dda72d2d6f4c81dbd4e41123f0bf281b19 (patch)
treed76bb03ccd7278e336e5952ad87b407a8450f6bf /app-editors
parentRevert "sys-fs/genfstab: keyword 28-r1 for sparc, bug #921377" (diff)
downloadgentoo-318644dda72d2d6f4c81dbd4e41123f0bf281b19.tar.gz
gentoo-318644dda72d2d6f4c81dbd4e41123f0bf281b19.tar.bz2
gentoo-318644dda72d2d6f4c81dbd4e41123f0bf281b19.zip
app-editors/emacs: Suppress false positive QA warnings
Bug: https://bugs.gentoo.org/898304 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-26.3-r16.ebuild3
-rw-r--r--app-editors/emacs/emacs-27.2-r14.ebuild3
-rw-r--r--app-editors/emacs/emacs-28.2-r10.ebuild3
-rw-r--r--app-editors/emacs/emacs-29.2.9999.ebuild3
-rw-r--r--app-editors/emacs/emacs-29.2.ebuild2
-rw-r--r--app-editors/emacs/emacs-30.0.9999.ebuild5
6 files changed, 18 insertions, 1 deletions
diff --git a/app-editors/emacs/emacs-26.3-r16.ebuild b/app-editors/emacs/emacs-26.3-r16.ebuild
index c5dc8e847acd..0a623b93b306 100644
--- a/app-editors/emacs/emacs-26.3-r16.ebuild
+++ b/app-editors/emacs/emacs-26.3-r16.ebuild
@@ -110,6 +110,9 @@ FULL_VERSION="${PV%%_*}"
S="${WORKDIR}/emacs-${FULL_VERSION}"
PATCHES=("${WORKDIR}/patch")
+# Suppress false positive QA warnings #898304
+QA_CONFIG_IMPL_DECL_SKIP=( malloc_{set,get}_state MIN )
+
src_prepare() {
default
diff --git a/app-editors/emacs/emacs-27.2-r14.ebuild b/app-editors/emacs/emacs-27.2-r14.ebuild
index a01d9a7a30d8..ec4f55ff0647 100644
--- a/app-editors/emacs/emacs-27.2-r14.ebuild
+++ b/app-editors/emacs/emacs-27.2-r14.ebuild
@@ -139,6 +139,9 @@ RDEPEND+=" ${IDEPEND}"
EMACS_SUFFIX="emacs-${SLOT}"
SITEFILE="20${EMACS_SUFFIX}-gentoo.el"
+# Suppress false positive QA warnings #898304
+QA_CONFIG_IMPL_DECL_SKIP=( malloc_{set,get}_state MIN )
+
src_prepare() {
if [[ ${PV##*.} = 9999 ]]; then
FULL_VERSION=$(sed -n 's/^AC_INIT([^,]*,[ \t]*\([^ \t,)]*\).*/\1/p' \
diff --git a/app-editors/emacs/emacs-28.2-r10.ebuild b/app-editors/emacs/emacs-28.2-r10.ebuild
index 82f4cb15df0f..e9b2026ad925 100644
--- a/app-editors/emacs/emacs-28.2-r10.ebuild
+++ b/app-editors/emacs/emacs-28.2-r10.ebuild
@@ -142,6 +142,9 @@ RDEPEND+=" ${IDEPEND}"
EMACS_SUFFIX="emacs-${SLOT}"
SITEFILE="20${EMACS_SUFFIX}-gentoo.el"
+# Suppress false positive QA warnings #898304
+QA_CONFIG_IMPL_DECL_SKIP=( malloc_{set,get}_state MIN )
+
src_prepare() {
if [[ ${PV##*.} = 9999 ]]; then
FULL_VERSION=$(sed -n 's/^AC_INIT([^,]*,[^0-9.]*\([0-9.]*\).*/\1/p' \
diff --git a/app-editors/emacs/emacs-29.2.9999.ebuild b/app-editors/emacs/emacs-29.2.9999.ebuild
index 1919adfa22cc..37292f4abff0 100644
--- a/app-editors/emacs/emacs-29.2.9999.ebuild
+++ b/app-editors/emacs/emacs-29.2.9999.ebuild
@@ -168,6 +168,9 @@ RDEPEND+=" ${IDEPEND}"
EMACS_SUFFIX="emacs-${SLOT}"
SITEFILE="20${EMACS_SUFFIX}-gentoo.el"
+# Suppress false positive QA warnings #898304
+QA_CONFIG_IMPL_DECL_SKIP=( malloc_{set,get}_state MIN static_assert alignof )
+
src_prepare() {
if [[ ${PV##*.} = 9999 ]]; then
FULL_VERSION=$(sed -n 's/^AC_INIT([^,]*,[^0-9.]*\([0-9.]*\).*/\1/p' \
diff --git a/app-editors/emacs/emacs-29.2.ebuild b/app-editors/emacs/emacs-29.2.ebuild
index c93571654cf7..bf54f38ebea3 100644
--- a/app-editors/emacs/emacs-29.2.ebuild
+++ b/app-editors/emacs/emacs-29.2.ebuild
@@ -171,7 +171,7 @@ RDEPEND+=" ${IDEPEND}"
EMACS_SUFFIX="emacs-${SLOT}"
SITEFILE="20${EMACS_SUFFIX}-gentoo.el"
-# Evade tinderbox bug #898304
+# Suppress false positive QA warnings #898304
QA_CONFIG_IMPL_DECL_SKIP=( malloc_{set,get}_state MIN static_assert alignof )
src_prepare() {
diff --git a/app-editors/emacs/emacs-30.0.9999.ebuild b/app-editors/emacs/emacs-30.0.9999.ebuild
index 73f31fed6ec7..286f87b9d183 100644
--- a/app-editors/emacs/emacs-30.0.9999.ebuild
+++ b/app-editors/emacs/emacs-30.0.9999.ebuild
@@ -169,6 +169,11 @@ RDEPEND+=" ${IDEPEND}"
EMACS_SUFFIX="emacs-${SLOT}"
SITEFILE="20${EMACS_SUFFIX}-gentoo.el"
+# Suppress false positive QA warnings #898304
+QA_CONFIG_IMPL_DECL_SKIP=(
+ malloc_{set,get}_state MIN static_assert alignof unreachable
+)
+
src_prepare() {
if [[ ${PV##*.} = 9999 ]]; then
FULL_VERSION=$(sed -n 's/^AC_INIT([^,]*,[^0-9.]*\([0-9.]*\).*/\1/p' \